• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 868
  • Last Modified:

"Must Change" is turned on

In SSMS 2008 I am trying to set my password so it doesn't force a password change. When I uncheck "Enforce Password Expiration" a popup errors:


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

The CHECK_POLICY and CHECK_EXPIRATION options cannot be turned OFF when MUST_CHANGE is ON. (Microsoft SQL Server, Error: 15128)

How do I turn off "Must_Change"? thanks!

Their link to a help file is worthless:
http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.1600&EvtSrc=MSSQLServer&EvtID=15128&LinkId=20476
0
Starr Duskk
Asked:
Starr Duskk
1 Solution
 
lcohanDatabase AnalystCommented:
just make sure all three (below) are unchecked if you want you login password to never expire and not check any policy:

"Specify old password"
"Enforce password policy"
"Enforce password expiration"
0
 
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
thanks! i'll give it a try!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now