Solved

Publishing is trying to connect using https and not http.

Posted on 2014-03-25
9
236 Views
Last Modified: 2014-03-29
First, thank you for your time.

I have created a LightSwitch application which basically means it's just a silverlight asp.net application.  Within IIS I have created a very vanilla, nothing special, website on port 85.  It is not configured with 1) a virtual directory, 2) an application, 3) a certificate, 4) any ssl security settings.   During the publish wizard steps I have said No to the Secure Connections question.  I believe this to mean use http and not https.

However, when I publish to my localhost website, the output says it cannot connect to website:  https://localhost:85.  I agree!  It shouldn't be able to connect using a secure connection on port 85.  But I didn't tell it to use a secure connection.

Why is it trying to connect using https and not http?

What should I check.  I am clearly missing something.

Again, thank you for your time.
0
Comment
Question by:MichaelDavidCarr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 27

Expert Comment

by:Sammy
ID: 39954224
On the publish wizard, what do you see in the Specify a certificate step?
Also, check the publish output step and look for the Server URL value and make sure it doesn't have https://
0
 

Author Comment

by:MichaelDavidCarr
ID: 39954660
Thank you for responding.

Here are the screen shots of the Publishing Wizard.  As you can see I am specifying that https is not required and no certificate.  The other screen shot is of the output window and there you can see that it is trying to connect using https.

I am pulling my hair out over this.  I need big help.

Thank you.

p.s.
Not that it makes any difference, but I made a slight typo in the original question.  I initially said I was using port 85 when actually I am using port 83.  oops.
vs-securitysettings.png
vs-specifycertificate.png
vs-output.png
0
 
LVL 52

Expert Comment

by:Carl Tawn
ID: 39956124
It may be down to the settings for the web app rather than the publishing option. In Visual Studio, from Project menu, select "<your application> Properties...". In the properties window that opens go to the "Web" tab then check the "Start Action" and "Servers" sections to see if either of them reference a HTTPS url.
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 

Author Comment

by:MichaelDavidCarr
ID: 39956611
Thank you for your time Carl.

I was hoping there would be, but unfortunately, I could not find any references to https.

Any other suggestions?
0
 
LVL 52

Expert Comment

by:Carl Tawn
ID: 39956857
Open up the .csproj file in notepad and look for the deployment related section (should be called something like <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'DEV-Deploy|AnyCPU'">), and see what it says. There may be some reference to https in there.
0
 

Author Comment

by:MichaelDavidCarr
ID: 39956931
I have already done that.  When I initially googled this problem I found this link:
http://blogs.msdn.com/b/david_kidder/archive/2012/12/05/declaring-lightswitch-publish-wizard-bankruptcy.aspx

This post outlines how to reset all the publishing settings in the PropertyGroup section.  I did that and still to no avail!
0
 
LVL 27

Expert Comment

by:Sammy
ID: 39962085
Look for this setting in your web.config and change it to false

 
  <add key="Microsoft.LightSwitch.RequireEncryption" value="True" />

Open in new window

0
 
LVL 52

Accepted Solution

by:
Carl Tawn earned 500 total points
ID: 39964004
On the "Application Server Configuration" tab of the publish wizard, double check the paths and URLs specified. If you've just specified "localhost:83" as the target URL, then it may be assuming "https", so make sure that you have explicitly stated the URL as "http://localhost:83".
0
 

Author Closing Comment

by:MichaelDavidCarr
ID: 39964082
Sammy's advice was good too, but it was Carl's solution that did the trick.  Thank you to both of you for helping me.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For those of you who don't follow the news, or just happen to live under rocks, Microsoft Research released a beta SDK (http://www.microsoft.com/en-us/download/details.aspx?id=27876) for the Xbox 360 Kinect. If you don't know what a Kinect is (http:…
Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question