IIS 7 - HTTP Error 404.17 - Not Found

Trying to browse to my website on my web server and I get the following error:

404-17 Not Found
LVL 17
Brad BouchardInformation Systems Security OfficerAsked:
Who is Participating?
 
Brad BouchardConnect With a Mentor Information Systems Security OfficerAuthor Commented:
I've decided to rebuild the server from scratch.

Thank all of you guys for helping me though.
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
from microsoft:

Open the IIS Manager

Expand the computer name and click "Application Pools" in the left pane.
Highlight the Application Pool hosting the resource in the middle pane.
In the far right pane click "Advanced Settings..."
In the Advanced settings dialog under the category "(General)", configure the following settings to match the handler requirements:
     .NET Framework Version
     Enable 32-Bit Applications
     Managed Pipeline Mode
0
 
Sivaraj ELead – IT InfrastructuresCommented:
What version of Framework your Application use ? Is your ISAPI set to what mode ? Is it allowing the right Framework version, Can you check these settings ?

Regards, Shiva
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
Brad BouchardInformation Systems Security OfficerAuthor Commented:
All of those settings are already correct.  

What do you mean by this...
configure the following settings to match the handler requirements:

Where do I find the handler requirements?
0
 
Brad BouchardInformation Systems Security OfficerAuthor Commented:
What version of Framework your Application use ?
4.0

Is your ISAPI set to what mode ?
ASP.NET_4.0.30319.0

Is it allowing the right Framework version
Not sure what you mean here?
0
 
Sivaraj ELead – IT InfrastructuresCommented:
Can you verify the below on your IIS whether you are allowing the right framework ?

ISAPIAllow your Framework
So the framework 4.0 should be allowed here,
Regards, Shiva
0
 
Brad BouchardInformation Systems Security OfficerAuthor Commented:
It is allowed... see screenshot

allowed
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
you can back up your web.config and web content, then revert your site's mappings to parent's, it should work for you(IIS Manager->high-light you web site->click Handler Mappings icon on the home pane->click Revert to Parent... on the right Actions pane).
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
also make sure classic asp is installed by default

 Control panel- Programs- Turn windows features on or off-under Internet information services

check all under Application development features and Security.
0
 
Brad BouchardInformation Systems Security OfficerAuthor Commented:
you can back up your web.config and web content, then revert your site's mappings to parent's, it should work for you(IIS Manager->high-light you web site->click Handler Mappings icon on the home pane->click Revert to Parent... on the right Actions pane)also make sure classic asp is installed by default

 Control panel- Programs- Turn windows features on or off-under Internet information services

check all under Application development features and Security.

Did all this... no luck...
0
 
Brad BouchardInformation Systems Security OfficerAuthor Commented:
Rebuilding the server from scratch; this way I have a clean slate
0
 
mwenenkoCommented:
All you needed is, in handler mappings, move your static file handler at the end of the order.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.