eMachine Won't Come on

I have an eMachine W3118 & when I turn it on, the fans spin on the CPU & in the power supply but no beeps or nothing & there is no display. I've took all components out & reseated them & c=blew the dust out but still the same issue....any suggestions?
LVL 15
wantabe2Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
David Johnson, CD, MVPConnect With a Mentor OwnerCommented:
you could try removing all of the ram and insert one sim at a time and see if you get anything in the post display (POST - Power On Self Test)
0
 
TRTurnerCommented:
I would look for dead capacitors

http://en.wikipedia.org/wiki/Capacitor_plague
0
 
dbruntonCommented:
I'd suspect a dead video graphics chipset.  See https://en.wikipedia.org/wiki/GeForce_6_Series#GeForce_61XX_abnormally_high_failure_rate_in_notebook_computers  I realise this ins't a notebook computer but I'd still suspect the graphics chipset.

Test with another monitor and test with booting from a boot CD.  If no joy then try the memory test as suggested above.  Try with no mouse and keyboard connected and no external devices connected.  Try with hard disk and CDROM drive and internal cards disconnected.  No joy then you could try a PSU or if there is sufficient space another graphics card.
0
 
nobusCommented:
use the minimum setup as described in my article ; it leads you very fast to the failing components :
http://www.experts-exchange.com/Hardware/Components/Motherboards/A_1945.html                  (Short-overview-of-how-to-troubleshoot-bad-hardware-when-a-pc-does-not-post)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.