Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SBS2003 - Can't Get To External Website...

Posted on 2014-03-25
15
Medium Priority
?
517 Views
Last Modified: 2014-03-26
OVERVIEW
Client has SBS2003

They named internal (aka Windows) domain same as public ( contoso.org)

Website was hosted externally at a provider, at 69.x.x.x

They could get to the website from inside the network, no problem

They moved the website to a new provider 184.x.x.x now they can't get to the website from inside.

EXTRA INFO
They did not tell the old provider they were moving so, it actually still goes the old website that is sitting on the old provider's server.

The website can be accessed by anyone outside of the network, it is resolving correctly.

COMMENTS
I did not set this up.

Yes I do know better than to do it like this.

I have been up and down DNS 20x looking for the www or 69.x.x.x entry, and can't find it.

What am I missing?

Its not in a host file.
0
Comment
Question by:tech911
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
15 Comments
 
LVL 8

Expert Comment

by:Camy
ID: 39954667
Tried using nslookup to check what it resolves to?
The old address is not just cached and needing ipconfig / flushdns ran?
0
 
LVL 8

Expert Comment

by:Camy
ID: 39954674
Also how is your DNS configured for resolving external addresses? Root hints or forwarded somewhere specific?
0
 
LVL 3

Author Comment

by:tech911
ID: 39954692
ipconfig /flushdns = No Joy

How can I tell if I am forwarded or root hint?

Can I be both?

There are forwarding entries and root hint entries.

DNSmgmt > DNSSERVER>Right Clk > Properties > Forwarding Tab, and Root Hints Tab.

Advise
0
Plug and play, no additional software required!

The ATEN UE3310 USB3.1 Gen1 Extender Cable allows users to extend the distance between the computer and USB devices up to 10 m (33 ft). The UE3310 is a high-quality, cost-effective solution for professional environments such as hospitals, factories and business facilities.

 
LVL 8

Expert Comment

by:Camy
ID: 39954722
Re-reading your post that might not be the best place to start anyway.

Just to confirm;

Your internal domain is contoso.org and your website is www.contoso,org?
You are entering www.contoso.org into a browser and getting the "old" site?
What happens if you ping www.contoso.org? You see the 69.x.x.x address?
what output do you get from running nslookup in a command prompt then typing "www.contoso.org"? Does it say "non-authoratative answer"?
0
 
LVL 3

Author Comment

by:tech911
ID: 39954801
NSLookup does give me the the 69.x.x.x address with the Non-Authoritative answer
0
 
LVL 8

Expert Comment

by:Camy
ID: 39954829
and the default server address that shows when you run nslookup is the DNS server you were looking on initially?

Its obviously resolving the old address somewhere, how long ago did they cutover to the new IP address?
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 39955576
Create a new DNS record:
1.Start DNS Manager by clicking Start, pointing to Programs, pointing to Administrative Tools, and then clicking DNS.
2.Expand your server branch, and then expand the Forward Lookup Zones branch.
3.Expand the DNS name zone.
4.On the Action menu, click New Host, and then type the name www (or other host name) in the New Host dialog box.
5.Type the IP address of the host. You can obtain this information by contacting your ISP, or by using the ping command from a computer that is not on your network. For example, you could ping www.mycompany.com from a computer on the Internet, and it should resolve with an IP address. You may want to confirm this address with your ISP. ISP-managed IP addresses are subject to change. If this happens, you will need to update the A record you created for "www" in your DNS zone.
Hope that helps,
Olaf
0
 
LVL 3

Author Comment

by:tech911
ID: 39955729
Olaf...

Lets think about this a little more.

It is currently resolving to a host out on the internet... 69.x.x.x the problem is that is the wrong host.

What we are trying to figure out is where that 69.x.x.x record is on the server.

Its not anywhere in DNS...So where do we look, that is the question.

My thought was that maybe there is a redirect page in IIS, but I don't know where to look to find it, it is IIS 6 / SBS-2003

Your additional thoughts are welcome.
0
 
LVL 8

Expert Comment

by:Camy
ID: 39955985
It wont be IIS as when you ping / nslookup "www.contoso.org" its resolving in DNS to the incorrect address. Olaf's solution should get you pointing to the correct place - im just not sure why you are resolving the old address with the current config.

What do the settings look like on the forwarders tab of the DNS server?
Set to forward to a specific IP address or two?
0
 
LVL 3

Author Comment

by:tech911
ID: 39956075
Their ISP is Cbeyond and its a T1, so the forwarders point to the Cbeyond DNS Servers.  Their are two IP addresses.
0
 
LVL 3

Author Comment

by:tech911
ID: 39956103
Olaf's solution is a no go... still resolving to old site.

That is what I thought would happen because I have tried that and tried creating a new zone with an alias, which also failed.

Your thoughts?
0
 
LVL 8

Accepted Solution

by:
Camy earned 2000 total points
ID: 39956110
so if you go back to the command prompt, run nslookup and type

server <Cbeyond DNS server IP>
www.contoso.org

Open in new window


Does this return the old or new IP?
0
 
LVL 3

Author Comment

by:tech911
ID: 39956143
It is pointing to the old 69.x.x.x IP
0
 
LVL 8

Expert Comment

by:Camy
ID: 39956195
Presumably it may also not have said "non-authoratitve"?

Looks like your server is forwarding the DNS query to the ISP's DNS server which is providing the incorrect / old address.

Depending on the TTL and time of change this still may be a timing / caching issue but if those are the servers to use you will need to give them a call i would think.
0
 
LVL 3

Author Closing Comment

by:tech911
ID: 39956255
As it turns out, it was the CBeyond DNS server not updating.  I put the google DNS server as the primary and an earthlink DNS server as the secondary.

Now it works.

Thanks for the help.
0

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question