• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 594
  • Last Modified:

Sonicwall Pro 2040 Lan To Lan RDP/DNS Config

Hi Experts.
I am a newbie to Sonicwall and require some of your expertise.

The Setup:
Sonicwall Pro 2040 X0 Port to LAN
Sonicwall Pro 2040 X1 Port to Internet
Sonicwall Pro 2040 X2 Port connected to a VLAN'd HP Procurve Switch with IP 192.168.xxx.254 on X2 and 192.168.xxx.250 on the switch port.  From the 192.168.xxx.xxx network I can ping the switch port and X2 interface IP's and I can ping to assets on the other subnet (which is 10.0.xxx.xxx) and vice versa.

The issue:
I cannot RDP from a system on the 10.0.xxx.xxx to a server on the 192.168.xxx.xxx network.  It also appears DNS traffic will not flow since I attempted to create a Stub Zone in DNS on the 192 network and it times out.

I suspect the firewall is not allowing the traffic to pass back and forth between the two subnets.  Any assistance would be greatly appreciated.
0
swlaurie
Asked:
swlaurie
  • 4
  • 2
1 Solution
 
carlmdCommented:
Do you have a firewall permit rule for X2 to X0 (I assume this is the 10.0,x.x) and vice versa?
The only permit by default is from the LAN to WAN.
0
 
swlaurieAuthor Commented:
Carlmd, how would I set that up in the GUI?
0
 
carlmdCommented:
I don't have access to a Sonicwall at the moment, but can give you detailed instructions tomorrow.

Briefly, you go to the firewall setting for LAN to WAN and add a rule.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
carlmdCommented:
The PRO2040 is quite old, so your menu may not match my instructions exactly but you should have similar settings. Login to Sonciwall as admin. I am assuming you have defined X2 as a LAN interface (you can check this under Network -> Interfaces).
 
1. Select Firewall -> Access Rules
2. From the matrix select LAN to LAN

Do you have a rule that has ANY for source, destination, and service?

If not add one. Click the Add button. Select ANY for the three drop downs and leave the rest at default.
0
 
swlaurieAuthor Commented:
Carlmd,
I have the LAN to LAN set to ANY as you instructed in your last post.  I still cannot RDP from an address on the 10 network to the server on the 192 network. Verified remote desktop is on...
0
 
carlmdCommented:
Did you verify that X2 is definded in the LAN zone? If so can you post the network settings for X0 and X2.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now