Exchange 2010 Room calendar permissions

I have a room set up in Exchange 2010 called "trainingroom". Users can book the room w/o any issues. but I'm running into issues where users can not open other meetings to view attendees and notes. I have other rooms where any user should be able to view meeting details.

if I open that calendar in outlook from a user who has "full access" permissions, i check the security permissions and it shows the Default user has "Reviewer" permissions.

doing some research, i noticed you could do the following:

get-mailboxpermissions -Identity trainingroom:\Calendar

however, when i do this, i get the following error:
the operation couldn't be performed because object 'trainingroom:\Calendar' couldn't be found on <insert dnsserver.domain.com here>

What do i need to do to allow any employee to double click and open meetings in the room calendars w/o negatively affecting their ability to book meetings and not giving them the ability to delete others' meetings.
LVL 5
HornAlumAsked:
Who is Participating?
 
stu29Connect With a Mentor Commented:
Try setting the permissions to custom level on the calendar, and then under READ area, change it from Free/Busy etc to full details for the appropriate user
0
 
HornAlumAuthor Commented:
"Reviewer" already has "full details" under the "Read" category.
0
 
stu29Connect With a Mentor Commented:
Try changing it for "Default" .. leave enough time for Exchange to realize the change (normally 15 minutes).
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
HornAlumAuthor Commented:
change what to default? the access type? there is no default. There's things like editor, author, reviewer, none, etc. (using outlook 2007)
0
 
stu29Commented:
Sorry  .. the Default User ..... change the Permission level to Custom ... Change READ to full ...
0
 
HornAlumAuthor Commented:
custom was not an option but i did change the "delete" to "own". the read was already set to full details. we'll see what that does.
0
 
HornAlumAuthor Commented:
that may have fixed it. there may have been a permission that was not set properly somewhere and changing the permissions ever so slightly resolved it. one of my test users can see the details now.

I'll follow up with the specific user on Monday that was having issues.
0
 
stu29Commented:
Great ... let me know how it works out?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.