Managing Public Folder Permissions


We recently taken over a SBS 2008 server and they needed some public folders created.

I logged into EMC and created the required folders within Public Folder Management Console but for some reason when I go into properties of the new folder I do not have the permissions to enable/disable what users get to access.

Am I doing it wrong or have I not set the right permissions for the new Admin account?

Who is Participating?
Md. MojahidConnect With a Mentor Commented:
To add permissions to a public folder you have 2 options:

Options 1 – Add the permissions per folder
Add-PublicFolderClientPermission -Identity "xxxxxx" -AccessRights Owner -User "Luke Smith"

Option 2 Recursively add permissions from a folder and all Child folders
 AddUsersToPFRecursive.ps1 -toppublicfolder -User "Luke Smith" -Permissions Owner

 The -User flag I original thought was the domain account such as TSLSLuke.Smith however it would appear that the command wanted the mailbox (display) name instead.
Have you check its Properties - Permission tabs yet? Make sure you have the Owner permission
MattTonerAuthor Commented:
That's the tab I'm unable to find when I click on properties
Also, please check this Library to understand in depth about public folder permission.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.