Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 776
  • Last Modified:

Cisco 2820 routing debug

I have a 2820 router connected to a 3550 switch. I have a server connected to switchport on the 3550 (vlan 342).

-I can ping the router gateway 10.2.42.254 from the server.
-I can also ping another interface on the router (vlan 132) 172.16.132.254.
-I can ping the 10.2.42.253 interface on the switch.
-I can NOT ping the 172.16.132.77 interface on the switch or anything on the (vlan 132) connected to that switch.

Layer 2 is working all the way through since I can ping anything on the (vlan 132) 172.16.132.0/24 network from the router and the switch.

I removed all the ACL's, still an issue. VLAN's are configured and it works on L2.

Switch: 132  VLAN0132                         active
            342  VLAN0342                         active
ECLUB-3550-Switch.txt
ECLUB-2800-RTR.txt
0
lconnell
Asked:
lconnell
3 Solutions
 
Craig BeckCommented:
I think you're trying to do something you don't need to do?

You're using (or trying/wanting to use) the 3550 as a layer-3 switch here, but I don't see why?  Your 2800 is doing the routing for your VLANs so why do you want more than one IP address on the 3550?  A management IP should be all you need.

I can see why you can't get to the IP address on the switch though - there's no default route on the switch.  You have a default gateway on the switch but that does a slightly different thing.

If you clear up what you're trying to achieve by adding routing to the 3550 that might fill in the blanks for me :-)
0
 
SouljaCommented:
Please show the entire configs, especially if you don't know what the issue is. Based on the partial config of the switch, you have it in layer 2 mode. You have the default gateway command in there which is used for Layer 2 mode. In layer 2 mode, you can only use one Layer 3 interface at a time.

This is just an assumption based on the partial config provided. If in fact the switch is in Layer 3 mode, then as Craig stated you need to add a default route.

Lastly, enable Layer 3 mode by entering ip routing.
0
 
lconnellAuthor Commented:
Hello,

So pinging the the 3550 really isn't what I am trying to achieve. I want to ping a device connected to the switch and I cannot do that.

-I can NOT ping  anything on the (vlan 132) from (vlan 342).
0
 
Hassan BesherCommented:
if you want to do routing based on the router not the switch:

1) make sure that pcs in vlan132 have gateway 172.16.132.8 and they are connected to switch interfaces has :
#sw mode acc
#sw acc vlan 132

2) make sure that pcs in vlan342  have gateway 10.2.42.254 and they are connected to switch interfaces has :
#sw mode acc
#sw acc vlan 342

3) make sure the router subinterfaces connected to switch trunk port with encap dot1q without any filtering

and you should be good to go!
0
 
lconnellAuthor Commented:
I don't have access to this equipment anymore so I can't troubleshoot any further.  I am assuming it was probably a gateway issue on one of the servers I was trying to access.

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now