Solved

Exchange 2010 Public Folder permission not taking effect when adding new users.

Posted on 2014-03-28
11
2,129 Views
Last Modified: 2014-04-06
I have added a new user and garnted him the Editor right in Exchange public folder management console but the change is not reflecting in the users outlook 2010 client. Normally the change on the server should take 2 hours but even after 2 days has gone by the permission for the public folder in the user's outlook client continue to display "Author" and not "Editor". I have even tried removing the the permission and adding it via exchange management shell but still not reflecting the change in the outlook client.
I have 2 DCs and 2 mailbox exchange mailbox servers. Both exchange and one DC are virtual servers.


Regards,

LealIT
0
Comment
Question by:LealIT
  • 6
  • 5
11 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39960990
If you look at the properties of the public folder from another user who has permissions, what does that show?

Simon.
0
 

Author Comment

by:LealIT
ID: 39960996
Other user who have permission of "Editor"
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39961004
You need to use someone who has Owner permission, which will show you all of the permissions. If you just look at another user who has less than owner then all you see is their own permissions.

Simon.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:LealIT
ID: 39961072
I Did give the permission using the domain admin account which is also the owner of the public folder. All other user that were explicitly  granted permission have editor permission. Anyboby else not explicitly granted permission have Author permission.
Now all existing users that appear in the permission list in PFMC have Editor permission when checked in their outlook client.
Now i have given same permission to a new recruit on the server but that is not reflecting on the client outlook 2010.


Hopes its a bit clearer now.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39961184
I know exactly what you did.
What I want you to do is look at the permissions of the folder through Outlook with a user who has Owner permissions. That will confirm if the permission is being seen by the clients correctly. The key bit here is to look at the folder with OUTLOOK, not public folder management tools on the server.

Simon.
0
 

Author Comment

by:LealIT
ID: 39961336
Ok cool and resolved but i'm not grasping the concept here.

So i log on to a pc with the account is the owner of the public folder and under permission i could see permissions for all the users except the new ones that i added on the Exchange Public folder management console.
It was only after i added the user there with the account of the owner of the Public folder and then checked it on the user's outlook that the permission got applied. This was instantaneous.

I followed the technet article below to add permission but the article describes giving the permission on EXchange server PFMC and does not anything about completing the permission assignment in outlook.
http://technet.microsoft.com/en-us/library/aa998834(v=exchg.141).aspx


So was i going at it the wrong way?

I mean should i have just given the permission in outlook with the account of the owner and not even touch the permission on the exchange server or both is required?


I hope you can shed some light about the above cause technet did not seem to have gone the additional mile explaining this.


Thanks for your promt response.


Regards,

LealIT
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39961381
I rarely, if even assign permissions using Exchange. I do almost all public folder management tasks through Outlook, including the creation of the public folder and then the assignment of the permissions. The main reason I do that is because I can then create the different types of folders.

However, the article you have posted is correct, and that process should have worked. Do you have multiple public folder databases at all? It could be a replication delay.

It may also be a problem with the folder itself, check if you can use PF management console to assign permissions on other folders.

Simon.
0
 

Author Comment

by:LealIT
ID: 39961531
Hi Simon,

Yes we do have multiple public folder databases. I have attached a snapshot of my public folders database replication setting.  When the option to "use public folder database replication scheduled is ticked" they dropdown menu for selecting the time for replication displayed Never Run and is grayed out.

Should this option be unticked and a replication time ie: "always run" be selected?

I will also try applying permissions with the PF management console to assign permissions on other folders like you suggested so a to know if the problem is with the folder itself.

I will post my findings once done.



Regards,


LealITpublic folder database replication setting
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39961841
You need to look at the properties of the public folder database itself.
That is the "master" replication setting, which should ideally be set to always run.

Simon.
0
 

Author Comment

by:LealIT
ID: 39971592
Hi Simmon,

I have set the replication on all my public folders to "always run" and after also tried applying permissions with the PF management console to assign permissions on other folders like you suggested so a to know if the problem is with the folder itself.
I have the same issue with as before, the permission set on the PF management console does not reflect in the client outlook.
If i assign the same permission in outlook with the owner account the permission is assigned instantly.

Since the permission applied instantly in outlook but not in the PFMC, i thinking that there is something else broken in my public folder other that replication.

Any ideas how i could fix my PFMC permission assignment issue?
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39975552
This isn't a problem I have seen.
You need to check whether it applies to another user logging in to the Exchange server with the correct permissions. That will confirm if it is a problem with the user profile or the tool. If it happens with someone else then it might be a tool issue.

Is the server fully up to date?

Simon.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question