How do I regain the ability to check/uncheck "Always ask before opening this type of file"?

We have a couple of users who need to access WordPerfect documents via our document management program; however, the user needs to come to a screen which looks like:

Open Package Contents
Do you want to open this file?
Open Cancel
check box for "Always ask before opening this type of file type"

However, what winds up happening is that somewhere in the registry, when you try to change the default program, you get a screen which looks like:

Open with
Choose the program you want to use to open this file:
Recommended Programs
Microsoft Word
Then
Checked and grayed out box, "Always use the selected program to open this kind of file".

The only way I've been able to revert back to the correct way is by creating a new profile.  Any other thoughts?

Thank you in advance.
Always-Check-Box.PNG
Grayed-Out-Box.PNG
rgreenbergAsked:
Who is Participating?
 
Dan CraciunConnect With a Mentor IT ConsultantCommented:
OK, so you want to remove the default file association?

Search for wpd in the following keys:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts
HKEY_CLASSES_ROOT

Delete the keys named "wpd", then kill and restart explorer.

HTH,
Dan
0
 
Dan CraciunIT ConsultantCommented:
I think that grayed out box is because Word is already the default application, so it would not make sense to set it as default again.
If you click on Wordpad (or choose another program) the "Always use" checkbox should activate.

HTH,
Dan
0
 
DeleteCommented:
Not sure if I understand your question correctly, but if you go into the "Control Panel -> Programs -> Default Programs -> Associate a file type or protocal with a program" then you can select what types of files each program opens.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
rgreenbergAuthor Commented:
I've done that and that would work if I were not opening the files through a database.  Because of the way the default is set up, the db doesn't like it.  It does like it though if the configuration is left as it should have been.
0
 
rgreenbergAuthor Commented:
If you look at the figure Always-Check-Box, this is what I want the user to see when they attempt to open a WordPerfect document through our database.  

If it is set to auto-open, the database just sits there not knowing what to do.
0
 
Rob HutchinsonDesktop SupportCommented:
I think all you have to do is copy one of the .wpd files to a folder on the hard drive or desktop then setup the file association that you're trying to setup.

It's when you try to associate the file while you are in another program?..other than Windows Exploder, that you cannot associate the file?
0
 
rgreenbergAuthor Commented:
Worked great and sorry it took so long to close this one with the answer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.