Solved

Microsoft Windows Server 2012 R2 Hyper V with Remote Desktop Services

Posted on 2014-03-28
7
10,477 Views
Last Modified: 2016-11-23
Recently installed a new Dell PowerEdge R520 for the first time with Windows Server 2012 R2 with x2 300GB drives for OS and a x3 RAID5 for general company data/hyper V.
32GB RAM with Intel(R) Xeon(R) CPU E5-2420 v2 @ 2.20GHz processors.

Basically get nothing running on the host apart from AD/DHCP/DNS and file sharing etc and got the Virtual 2012 R2 machine setup as per screenshot.
Even after trying to increase the RAM and virtual processors it's running shocking slow speeds when users remote into it and open up SAGE or their 3mb Database which runs off of a mapped drive. Everything is fine internally in the company with the computers in the domain not experiencing any lag. I feel I've missed something with the Virtual Machine config as at the moment it's slower then previous 2008 box which only had 2GB RAM.
Only difference being it was a physical box they were remotely connecting into not a virtual machine.

The 2012 Host AD Domain controller is using NIC2 and is configured as standard i.e. not on VM Switch.
The Terminal Server is running on the 1st NIC which is configured under Hyper-V Extensible Virtual Switch protocol. This seemed just did this as standard when setting up the VM.

only thing I noticed was getting this in event ID:-  Remote Desktop Services has taken too long to load the user configuration from server \\servername.local for user joe bloggs

Just wondered if anyone had any ideas what could be causing the speed issue with the Virtual Machine or confirmed they have had success with Remote Desktop Services via Hyper v? Also has the licensing changed since 2008 R2? they have 15 cals but I notice the count is going down every time a user logs in does this mean once 15 people have logged in it won't let any new user log into it and they would have to buy more cals as I thought it was concurrent ?

Much appreciate any help or advise on this one as I'm thinking I might have to try a re-install or consider hosting it on a Physical box and using Hyper-V for Remote Desktop Services was a bad idea:(
VM-NIC.jpg
VM-Processor-config.jpg
VM-RAM-config.jpg
0
Comment
Question by:CRL ltd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 17

Expert Comment

by:Brad Bouchard
ID: 39962887
I know this sounds really counterintuitive, but take the vCPUs down to 1 and try out the server.  Increase to 2 if 1 seems ok but slower, and if 2 is ok leave it.  We have seen issues with too many vCPUs in the past.
0
 
LVL 17

Expert Comment

by:Brad Bouchard
ID: 39962901
Also has the licensing changed since 2008 R2? they have 15 cals but I notice the count is going down every time a user logs in does this mean once 15 people have logged in it won't let any new user log into it and they would have to buy more cals as I thought it was concurrent ?

CALs work like they always have; if you have 15 users and you are going to buy user CALs then you need 15 of them.  You should receive a warning at 15 or even less but it won't affect you for awhile.  You will definitely need to buy more though if you are approaching that.
0
 
LVL 1

Author Comment

by:CRL ltd
ID: 39962996
ok thank you I will try that and report back.
So the the CALS aren't tied to the user in Active Directory? I was just thinking for example if I disable a user account and setup a new one to login as a remote user it should be ok?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 1

Author Comment

by:CRL ltd
ID: 39963040
ok definitely no improvement on changing the Virtual Processor down to 1 or 2.
0
 
LVL 1

Accepted Solution

by:
CRL ltd earned 0 total points
ID: 39963082
after researching found this to be the solution.

Verify in your Server NIC if have a option called " Virtual Machine Queue" and disable it.

The Broadcom have an incompatibility with the Hyper-V in Windows Server 2012, but your NIC maybe have the same configuration:
http://fundamentallygeek.blogspot.com.br/2012/11/slow-network-access-within-virtual.html
0
 
LVL 1

Author Closing Comment

by:CRL ltd
ID: 39971731
this fixed my issue after finding the answer myself elsewhere
0
 

Expert Comment

by:Member_2_5163268
ID: 41819664
No, that doesn't made a difference for me ! Any other hints ?
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Is your company's data protection keeping pace with virtualization? Here are 7 dynamic ways to adapt to rapid breakthroughs in technology.
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
In this Micro Tutorial viewers will learn how to use Windows Server Backup to create full image of their system. Tutorial shows how to install Windows Server Backup Feature on Windows 2012R2 and how to configure scheduled Bare Metal Recovery backup.…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question