Solved

VPN tunnel failing between asa 5510 and Draytek 2955

Posted on 2014-03-29
17
1,183 Views
Last Modified: 2014-04-26
I am trying to setup a VPN tunnel between an asa 5510 and a draytek 2955. I believe the latter is causing some issues but I cant figure out what.

Phase 1 completes ok but phase 2 is not.

on the gui I can see that IKEv1 is up but ipsec is not. and traffic is null

the logs shows a few item:

connection terminated for peer reason peer terminate remote proxy
cisco asa duplicate phase 2 packet detected
removing peer from correlator table failed, no match

here is the config  (as you can see there is another tunnel and that one works fine)

Result of the command: "sh run"

: Saved
:
ASA Version 8.6(1)2 
!
hostname asan-sf-asa
enable password FRx0uWtLwmqV/zMC encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface GigabitEthernet0/0
 nameif Outside
 security-level 0
 ip address x.x.x.194 255.255.255.248 
!
interface GigabitEthernet0/1
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/1.1
 vlan 40
 nameif Data
 security-level 100
 ip address 10.11.40.1 255.255.255.0 
!
interface GigabitEthernet0/1.2
 vlan 41
 nameif SAN
 security-level 100
 ip address 10.11.41.1 255.255.255.0 
!
interface GigabitEthernet0/1.3
 vlan 42
 nameif Voice
 security-level 100
 ip address 10.11.42.1 255.255.255.0 
!
interface GigabitEthernet0/1.4
 vlan 99
 nameif WIFI-Guest
 security-level 0
 ip address 10.11.99.1 255.255.255.0 
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 nameif Testing
 security-level 100
 ip address 10.11.50.1 255.255.255.0 
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
 management-only
!
boot system disk0:/asa861-2-smp-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network Data
 subnet 10.11.40.0 255.255.255.0
object network SAN
 subnet 10.11.41.0 255.255.255.0
object network Voice
 subnet 10.11.42.0 255.255.255.0
object network WIFI-Guest
 subnet 10.11.99.0 255.255.255.0
object network NETWORK_OBJ_10.11.39.192_27
 subnet 10.11.39.192 255.255.255.224
object network London
 subnet 192.168.28.0 255.255.252.0
 description London
object network Amsterdam
 subnet 10.11.30.0 255.255.255.0
 description Amsterdam
object-group network DM_INLINE_NETWORK_1
 network-object 10.11.40.0 255.255.255.0
 network-object 10.11.42.0 255.255.255.0
 network-object 192.168.1.0 255.255.255.0
access-list Data_access_out extended permit ip object Data any 
access-list SAN_access_out extended permit ip object SAN any 
access-list Voice_access_out extended permit ip object Voice any 
access-list WIFI-Guest_access_out extended permit ip object WIFI-Guest any 
access-list asanVPN_splitTunnelAcl standard permit 10.11.40.0 255.255.255.0 
access-list asanVPN_splitTunnelAcl standard permit 10.11.42.0 255.255.255.0 
access-list asanVPN_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0 
access-list Outside_cryptomap extended permit ip object Data object London 
access-list Outside_cryptomap_1 extended permit ip object Data object Amsterdam 
pager lines 24
logging enable
logging asdm debugging
logging class vpn asdm debugging 
mtu Outside 1500
mtu Data 1500
mtu SAN 1500
mtu Voice 1500
mtu WIFI-Guest 1500
mtu Testing 1500
mtu management 1500
ip local pool VPNpool 10.11.39.200-10.11.39.209
ip local pool VPNdatapool 10.11.40.250-10.11.40.251
icmp unreachable rate-limit 1 burst-size 1
icmp permit any Outside
icmp permit any Data
asdm image disk0:/asdm-66114.bin
no asdm history enable
arp timeout 14400
nat (Data,Outside) source static DM_INLINE_NETWORK_1 DM_INLINE_NETWORK_1 destination static NETWORK_OBJ_10.11.39.192_27 NETWORK_OBJ_10.11.39.192_27 no-proxy-arp route-lookup
nat (Data,Outside) source static Data Data destination static London London
nat (Data,Outside) source static Data Data destination static Amsterdam Amsterdam
!
object network Data
 nat (Data,Outside) dynamic interface
object network SAN
 nat (SAN,Outside) dynamic interface
object network Voice
 nat (Voice,Outside) dynamic interface
object network WIFI-Guest
 nat (WIFI-Guest,Outside) dynamic interface
access-group Data_access_out in interface Data
access-group SAN_access_out in interface SAN
access-group Voice_access_out in interface Voice
access-group WIFI-Guest_access_out in interface WIFI-Guest
route Outside 0.0.0.0 0.0.0.0 x.x.x.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
http server enable 444
http 192.168.1.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 Data
http 0.0.0.0 0.0.0.0 Outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec ikev1 transform-set 3DES esp-3des esp-sha-hmac 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map Outside_map 1 match address Outside_cryptomap
crypto map Outside_map 1 set pfs group5
crypto map Outside_map 1 set peer London
crypto map Outside_map 1 set ikev1 transform-set ESP-AES-128-MD5 ESP-AES-256-MD5
crypto map Outside_map 2 match address Outside_cryptomap_1
crypto map Outside_map 2 set pfs group5
crypto map Outside_map 2 set connection-type answer-only
crypto map Outside_map 2 set peer Ams
crypto map Outside_map 2 set ikev1 transform-set ESP-3DES-SHA ESP-3DES-MD5
crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map Outside_map interface Outside
crypto ikev1 enable Outside
crypto ikev1 policy 10
 authentication crack
 encryption aes-256
 hash md5
 group 5
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash md5
 group 5
 lifetime 86400
crypto ikev1 policy 30
 authentication pre-share
 encryption aes-256
 hash md5
 group 5
 lifetime 86400
crypto ikev1 policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication crack
 encryption aes
 hash md5
 group 5
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash md5
 group 5
 lifetime 86400
crypto ikev1 policy 90
 authentication pre-share
 encryption aes
 hash md5
 group 5
 lifetime 86400
crypto ikev1 policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 70.35.53.192 255.255.255.224 Outside
ssh 0.0.0.0 0.0.0.0 Data
ssh 10.11.40.0 255.255.255.0 Data
ssh timeout 5
console timeout 0
management-access Data
dhcpd address 10.11.40.50-10.11.40.100 Data
dhcpd dns 10.11.40.20 75.75.75.75 interface Data
dhcpd wins 10.11.40.20 interface Data
dhcpd domain asan.local interface Data
dhcpd enable Data
!
dhcpd address 10.11.42.50-10.11.42.200 Voice
dhcpd dns 75.75.75.75 75.75.76.76 interface Voice
dhcpd domain asan interface Voice
dhcpd option 150 ip 10.11.42.254 interface Voice
dhcpd enable Voice
!
dhcpd address 10.11.99.50-10.11.99.200 WIFI-Guest
dhcpd dns 75.75.75.75 75.75.76.76 interface WIFI-Guest
dhcpd domain asan interface WIFI-Guest
dhcpd enable WIFI-Guest
!
dhcpd address 10.11.50.50-10.11.50.200 Testing
dhcpd dns 75.75.75.75 75.75.76.76 interface Testing
dhcpd domain asan interface Testing
dhcpd enable Testing
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 209.167.68.100
ntp server 169.229.70.201
ntp server 209.123.234.24
ntp server 74.207.245.227
webvpn
group-policy GroupPolicy_london internal
group-policy GroupPolicy_london attributes
 vpn-tunnel-protocol ikev1 
group-policy GroupPolicy_ams internal
group-policy GroupPolicy_ams attributes
 vpn-tunnel-protocol ikev1 
group-policy asanVPN internal
group-policy asanVPN attributes
 dns-server value 8.8.8.8
 vpn-tunnel-protocol ikev1 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value asanVPN_splitTunnelAcl
username support password dnQpMAMuBN.02U.N encrypted privilege 15
username support attributes
 vpn-group-policy asanVPN
username ipsofacto password ZWLHvi5DbsK7KXyD encrypted privilege 15
username ipsofacto attributes
 vpn-group-policy asanVPN
tunnel-group asanVPN type remote-access
tunnel-group asanVPN general-attributes
 address-pool VPNpool
 default-group-policy asanVPN
tunnel-group asanVPN ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group london type ipsec-l2l
tunnel-group london general-attributes
 default-group-policy GroupPolicy_london
tunnel-group london ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
tunnel-group ams type ipsec-l2l
tunnel-group ams general-attributes
 default-group-policy GroupPolicy_ams
tunnel-group ams ipsec-attributes
 ikev1 pre-shared-key *****
 isakmp keepalive threshold 20 retry 2
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
Cryptochecksum:21187e3e901c33308a35f5fdb8bb5651
: end

Open in new window


thx in advance for your help
0
Comment
Question by:odewulf
  • 10
  • 7
17 Comments
 

Author Comment

by:odewulf
Comment Utility
FYI I tested by having the asa dialing out instead of the draytek and now the tunnel is up (ipsec as well) but there is still not traffic going through.

if I checked the tunnel status, IPSEC shows that the remote and local IPs are the external IPs instead of being the internal IP???

I am not familiar at all with the draytek but just wondering if this is what is causing the issue here.
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Looks like it's likely to be an order of operations issue.  Looks like object Data get's dynamically NAT'd when it goes out the outside interface.  Since NAT takes place before crypto, it will prevent the traffic from being caught by the VPN.

You need to make it so that if the destination is an internal network, the traffic does not get NAT'd.
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Whoops!  Nevermind, I found the entry not to NAT traffic from Data to Amsterdam.
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Can you provide the output of show crypto ipsec sa?
0
 

Author Comment

by:odewulf
Comment Utility
Result of the command: "show crypto ipsec sa"

this is for the tunnel that is working. not showing info about the one that is not working

interface: Outside
    Crypto map tag: Outside_map, seq num: 1, local addr: x.x.x.x

      access-list Outside_cryptomap extended permit ip 10.11.40.0 255.255.255.0 192.168.28.0 255.255.252.0
      local ident (addr/mask/prot/port): (10.11.40.0/255.255.255.0/0/0)
      remote ident (addr/mask/prot/port): (192.168.28.0/255.255.252.0/0/0)
      current_peer:y.y.y.y

      #pkts encaps: 32417, #pkts encrypt: 32417, #pkts digest: 32417
      #pkts decaps: 49016, #pkts decrypt: 49016, #pkts verify: 49016
      #pkts compressed: 0, #pkts decompressed: 0
      #pkts not compressed: 32417, #pkts comp failed: 0, #pkts decomp failed: 0
      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
      #send errors: 0, #recv errors: 0

      local crypto endpt.: x.x.x.x.x/0, remote crypto endpt.: y.y.y.y./0
      path mtu 1500, ipsec overhead 74, media mtu 1500
      current outbound spi: CEC64859
      current inbound spi : AD0C8359

    inbound esp sas:
      spi: 0xAD0C8359 (2903278425)
         transform: esp-aes esp-md5-hmac no compression
         in use settings ={L2L, Tunnel, PFS Group 5, }
         slot: 0, conn_id: 224014336, crypto-map: Outside_map
         sa timing: remaining key lifetime (sec): 2099
         IV size: 16 bytes
         replay detection support: Y
         Anti replay bitmap:
          0xFFFFFFFF 0xFFFFFFFF
    outbound esp sas:
      spi: 0xCEC64859 (3469101145)
         transform: esp-aes esp-md5-hmac no compression
         in use settings ={L2L, Tunnel, PFS Group 5, }
         slot: 0, conn_id: 224014336, crypto-map: Outside_map
         sa timing: remaining key lifetime (sec): 2099
         IV size: 16 bytes
         replay detection support: Y
         Anti replay bitmap:
          0x00000000 0x00000001
0
 

Author Comment

by:odewulf
Comment Utility
if the draytek is setup to dial in and the asa to dial out then the tunnel is up but still not traffic and here is what I see

 Crypto map tag: Outside_map, seq num: 2, local addr: 50.204.141.194

      access-list OO_temp_Outside_map2 extended permit ip host 50.204.141.194 host 213.127.204.202
      local ident (addr/mask/prot/port): (x.x.x.x/255.255.255.255/0/0)
      remote ident (addr/mask/prot/port): (z.z.z.z/255.255.255.255/0/0)
      current_peer: z.z.z.z

      #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
      #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
      #pkts compressed: 0, #pkts decompressed: 0
      #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
      #send errors: 0, #recv errors: 0

      local crypto endpt.: x.x.x.x/0, remote crypto endpt.: z.z.z.z/0
      path mtu 1500, ipsec overhead 74, media mtu 1500
      current outbound spi: F29DF52B
      current inbound spi : 0997F1C4

    inbound esp sas:
      spi: 0x0997F1C4 (160952772)
         transform: esp-aes esp-sha-hmac no compression
         in use settings ={L2L, Tunnel, }
         slot: 0, conn_id: 224124928, crypto-map: Outside_map
         sa timing: remaining key lifetime (kB/sec): (3915000/28712)
         IV size: 16 bytes
         replay detection support: Y
         Anti replay bitmap:
          0x00000000 0x00000001
    outbound esp sas:
      spi: 0xF29DF52B (4070438187)
         transform: esp-aes esp-sha-hmac no compression
         in use settings ={L2L, Tunnel, }
         slot: 0, conn_id: 224124928, crypto-map: Outside_map
         sa timing: remaining key lifetime (kB/sec): (3915000/28712)
         IV size: 16 bytes
         replay detection support: Y
         Anti replay bitmap:
          0x00000000 0x00000001
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
access-list OO_temp_Outside_map2 extended permit ip host 50.204.141.194 host 213.127.204.202
Your access list only specifies traffic from the public IPs.

You need to replace this access list with one that specifies the internal LANs.

And you'd need to make the same change on the other end of the VPN.
0
 

Author Comment

by:odewulf
Comment Utility
it is setup that way as you can see on the asa config and it is setup that way as well on the draytek.
I believe it is a bug on the draytek. I open a ticket with them.

thx
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 28

Expert Comment

by:asavener
Comment Utility
Did you have an access list named "OO_temp_Outside_map2" at one point?

I've seen ASAs just not work right after multiple edits to the crypto config.  Removing the config and re-adding, running clear crypto commands, etc. had no effect.  The only thing to fix the issue was a reboot.
0
 

Author Comment

by:odewulf
Comment Utility
no i didnt. I will reboot the firewall tonight to clear the config though and let you know if that helps

thx
0
 

Author Comment

by:odewulf
Comment Utility
FYI restarting didn't help. Draytek support mentioned to upgrade the firmware. I will do that and let you know
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Just curious, but does "show crypto ipsec sa" show the same access list?
0
 

Author Comment

by:odewulf
Comment Utility
I am not sure what you mean. Show crypto ipsec sa shows the access list I pasted above.

the upgrade didn't seem to fix the issue. still working with draytek support
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Did you reboot the ASA?
0
 

Author Comment

by:odewulf
Comment Utility
I did and upgraded the firmware
0
 

Accepted Solution

by:
odewulf earned 0 total points
Comment Utility
FYI the firmware upgrade was the solution.

thx for your help anyway

G
0
 

Author Closing Comment

by:odewulf
Comment Utility
Firmware upgrade
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now