Not receiving external inbound Exchange email

None of our Ex2010 users are receiving external inbound email.

We have the following:
All inbound email hits our Ex 2003 Bridge Server before either passing the mail onto Outlook 2003 mailboxes, or onto our HubCas Ex 2010 server for 100 Outlook 2010 users.

All Outbound email also pipes through the 2003 Bridge server so at the moment all 2003 mailboxes/users can send and receive internal and external emails so no problems there.

The 100 Ex2010 mailboxes can send internal and external Outbound email, However, No Ex 2010 mailboxes are receiving any external inbound email which is currently queuing on the 2003 Bridgehead server.

No one is aware of any changes been made so the only area I believe I should be looking at is the Legacy Routing Group Connector on the 2003 Bridgehead server, however, I don't want to make any changes and cause other issues.
LVL 2
CTCRMInfrastructure EngineerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
CTCRMConnect With a Mentor Infrastructure EngineerAuthor Commented:
Hi Guys
After some hours looking at this it turns out that Ex 2010 will not accept remote mail unless the pickup queue is located on a server with a minimum of 4GB free space, by default this is the C:\Drive. Our HUBCAS server had less than 4GB of free space on it!! and this caused the queues to be processed.

Other items to consider-
After the server is rebooted, and even with less than 4GB it will accept mail for a short time (just to confuse matters....)
The free space will shrink and grow a little with server maintenance, so don't just look at a disk with 5GB and say, all is well....
And to make life just a little bit more confusing, from what we have experiienced there are absolutely NNNNNNNNo announcements in the server log files about the queue shutdown.
0
 
yuvalattarsys admin (microsoft and Linus)Commented:
Dear CTCRM,
3. check whether the Exchange server can go outside to the internet (surf the net).
2. does your Exchnage server has an outside IPAddress (NAT)? do you have a firewall?
1. check the rules on that firewall.
best of luck
0
 
Ben HartCommented:
No NDRS being generated and sent to those external senders? You check the log files?
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
CTCRMInfrastructure EngineerAuthor Commented:
The Ex2003 Bridge server can surf the public web
The Ex2010 Hub Transport can also surf the web
NAT is dealt with at the company's firewall and no changes have been made

The inbound external emails are coming into the business and queued on the Ex 2003 Bridgehead server. If the incoming mail is destined for any of the 900 2003 users mailboxes they're receiving those emails.
If the incoming email is destined for 2010 mailboxes those emails are just queuing on the Ex 2003 Bridge server so doesn't seem to know what to do with them. Maybe the Exchange 2003 Legacy connector isn't doing what it should be doing.

I'm going to get some logs and NDRs generated.
0
 
Ben HartCommented:
So the queue's are filling up for the 2010 mailboxes right?  My memory of 2003 is fuzzy but possibly recreating the receive connector between 2003 and 2010?
0
 
CTCRMInfrastructure EngineerAuthor Commented:
Is that the receive connector on the 2010 HubCAS server?
0
 
CTCRMInfrastructure EngineerAuthor Commented:
The inbound email for 2010 mailboxes is currently queuing on the Ex 2003 Bridge server. The mail hits the 2003 Bridge and that is where it is staying (only mail for 2010 users mailboxes).
0
 
Simon Butler (Sembee)ConsultantCommented:
What does the queue viewer say?
Can you telnet to the Exchange 2010 server?

The reference to connector above is probably about the routing group connector. Recreating that is certainly something I would consider, it is one of the more common causes of this problem.

Simon.
0
 
CTCRMInfrastructure EngineerAuthor Commented:
We have recreated the Routing Group
The Queue Viewer shows 'Unreachable Domain' on the 'Queue' tab and there are around 20,000 messages listed on the 'Messages' tab.

I can ping the Master DC which holds the Global Catalog and it seems now that no Ex 2010 mailboxes can send or receive emails internally & externally.

I have run a 'Remote Connectivity Analyser against 2010 mailboxes and they are successful.

We only have on receiver connector on the HubCAS which is a 'Legacy' connector for linking 2003 and 2010.
0
 
Simon Butler (Sembee)ConsultantCommented:
"We only have on receiver connector on the HubCAS which is a 'Legacy' connector for linking 2003 and 2010. "

That isn't correct.
You should have two Receive Connectors, a Default and a Client Receive Connector. No other connectors are required.
Did you delete those? If you did that was the wrong thing to do.

I suspect that is the cause of your problems, as the server cannot route email correctly.

The Default Receive Connector should have these settings for Authentication:

TLS
Basic Authentication
Offer Basic only after starting TLS
Exchange Server
Integrated.

Permissions: All but partners.

Client Connector, as above, but no Exchange Server authentication and on Permission Group only Exchange users.

Simon.
0
 
CTCRMInfrastructure EngineerAuthor Commented:
Hi Simon

My mistake, I meant one connector that we had created so excluding the 2 default connectors.

I have removed the Legacy connector, waited 10 mins for the Exchange Routing config to refresh and then recreated it, then restarted the Ex Transport service.
0
 
Simon Butler (Sembee)ConsultantCommented:
You don't need any legacy connector at all.
The default connector is enough, so I would remove the additional connector completely and then restart the transport service.

Ensure that you do not have any restrictions on the Connectors which would stop the connection from happening.

Simon.
0
 
yuvalattarsys admin (microsoft and Linus)Commented:
1.check whether your server answer for port 25 .
2. check the security on the smtp connector.
3. rebuild a new smtp connector.
0
 
CTCRMInfrastructure EngineerAuthor Commented:
Resolved
0
 
Simon Butler (Sembee)ConsultantCommented:
That is back pressure.
http://technet.microsoft.com/en-us/library/bb201658(v=exchg.141).aspx
Something should have been logged though.

Simon.
0
 
CTCRMInfrastructure EngineerAuthor Commented:
Resolved through own research
0
All Courses

From novice to tech pro — start learning today.