config ssg-20 juniper router

Hi,

I have a SSG-20 router at workplace. Never worked with them. I have to use CLI. I need to change the port forwarding.

For example the CLI shows : set interface ethernet 0/0 vip interface-ip 90 "http" 192.168.1.55 manual.

I want to change the "http" to a port number? Can i also get a list of commands?

What are the commands i should i be using to edit ?

Thanks
LVL 4
o0JoeCool0oAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
o0JoeCool0oConnect With a Mentor Author Commented:
had to call Juniper and got the issue resolved by them.
0
 
Sanga CollinsSystems AdminCommented:
What port number do you want to change HTTP to? You will need to create a custom service first if it is not a port that is part of the preloaded services.

Also just curious, is there any specific reason you can not use the webinterface? If you can connect via web, this process would be a breeze.
0
 
o0JoeCool0oAuthor Commented:
9675 is the port number. i juts want to change the "http" to a port number 9675 for a external website.

I am not able the router though a web interface
0
Become a Leader in Data Analytics

Gain the power to turn raw data into better business decisions and outcomes in your industry. Transform your career future by earning your MS in Data Analytics. WGU’s MSDA program curriculum features IT certifications from Oracle and SAS.  

 
Sanga CollinsSystems AdminCommented:
ok, then you will have to create a custom service using this command

set service "http9675" protocol tcp src-port 0-65535 dst-port 9675-9675
set interface ethernet 0/0 vip interface-ip 90 "http9675" 192.168.1.55
0
 
o0JoeCool0oAuthor Commented:
for some reason its not working for me. any idea as how can i enable web-interface on this router so that it can be easy?
0
 
QlemoDeveloperCommented:
You should be able to use the Web GUI if you try from a local machine, e.g. RDP.  Or, if you have a VPN connectiion to the router, that one should work too.
Exception is, of course,  if anybody switched off Web GUI on all interfaces, or restricted it to managed IPs (allowing only specific IP addresses to access it).
0
 
Sanga CollinsSystems AdminCommented:
you need to know what interface you are connecting to the device from. So first thing to do is:

get interface

Then using the name of the appropriate interface from the results

set interface ethernet0/2 manage web


Please note ethernet0/2 is an example, you must use the actual interface name appropriate for how you are connected
0
 
o0JoeCool0oAuthor Commented:
juniper tech team fixed the issue for me. it was a firmware issue.
0
All Courses

From novice to tech pro — start learning today.