Solved

Group Policy Files - Access Denied Error 4098

Posted on 2014-04-01
8
3,661 Views
1 Endorsement
Last Modified: 2015-03-18
Dear Experts,

I have a computer GPO which is set to do 2 things:
1) Copy a file from a network share to all users profile desktop
2) Delete a specific file called "Remote Desktop.RDP" from all users profile desktop.

I use group policy preferences --> file to do this. The copying of the file works absolutely perfectly, however, the deleting of the file from the desktop only works on Windows XP machines. For Win 7 machines in the event viewer you get the following 4098 error:

The computer 'Remote Desktop.RDP' preference item in the 'Desktop Icons {84149EEF-6A4E-49A5-91E3-6638166B6663}' Group Policy object did not apply because it failed with error code '0x80070005 Access is denied.' This error was suppressed.

Any ideas?
1
Comment
Question by:Bladey001
8 Comments
 
LVL 15

Expert Comment

by:max_the_king
ID: 39968903
Hi,
if you're using a user GPO you may try and check "Run in logged-in user's security context".
It once made me solve a similar problem

hope this helps
max
0
 

Author Comment

by:Bladey001
ID: 39969141
Tried adding the user setting into the same GPO and selecting that but still no luck :(
0
 
LVL 15

Expert Comment

by:max_the_king
ID: 39969383
please keep in mind that computer's gpo sa priority over user's gpo
0
 
LVL 79

Expert Comment

by:David Johnson, CD, MVP
ID: 39970571
because it is an all users shortcut a standard user cannot delete it ergo you need to do it in the computer preferences and not the user preferences.
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 

Author Comment

by:Bladey001
ID: 39977607
So any other ideas?
0
 

Accepted Solution

by:
Bladey001 earned 0 total points
ID: 40001811
I managed to get around this by putting the direct path i.e. C:\Users\Public\Desktop

I guess it must not have like the %ALLUSERSPROFILE%
0
 

Author Closing Comment

by:Bladey001
ID: 40011175
Solved by doing this workaround
0
 

Expert Comment

by:jollywhitefoot
ID: 40673277
This is old, but I thought I would chime in.  The reason this worked on XP but did not work on Windows 7 machines when using the variable %ALLUSERSPROFILE% is because the variable in Windows 7 for the Public folder is %PUBLIC%.  In Windows 7 %ALLUSERSPROFILE%  is for ProgramData.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

To effectively work with Diskpart on a Server Core, it is necessary to write some small batch script's, because you can't execute diskpart in a remote powershell session. To get startet, place the Diskpart batch script's into a share on your loca…
You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now