?
Solved

create new public folder database, change path to existing public folder database

Posted on 2014-04-01
4
Medium Priority
?
213 Views
Last Modified: 2014-04-04
Greetings,

I asked this question and didn't get much feedback. http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_28400254.html

My public folder database is mounted, but there are no properties. We are unable to send emails to any account on that database. We get an error that the object doesn't exist in AD. There are no error logs in AD or on exchange about this.

Can I create a new PF database and then point the path to the existing PF database? If not, can I create a new PF database then migrate the info from the current I guess corrupt PF database to the new one?

Thanks for any help. This is a real pain.
0
Comment
Question by:rpliner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
4 Comments
 
LVL 7

Author Comment

by:rpliner
ID: 39969465
it appears the database is OK. Still can't email to it, Checked AD again and the expected objects are not there. Here is eseutil in case I missed something.

Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
Version 14.03
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating FILE DUMP mode...
         Database: Public Folder Database 0131202575.edb


DATABASE HEADER:
Checksum Information:
Expected Checksum: 0x1e1eaf30
  Actual Checksum: 0x1e1eaf30

Fields:
        File Type: Database
         Checksum: 0x1e1eaf30
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,17
 Engine ulVersion: 0x620,17
Created ulVersion: 0x620,17
     DB Signature: Create time:06/21/2013 19:33:51 Rand:12802377 Computer:
         cbDbPage: 32768
           dbtime: 1715126 (0x1a2bb6)
            State: Clean Shutdown
     Log Required: 0-0 (0x0-0x0)
    Log Committed: 0-0 (0x0-0x0)
   Log Recovering: 0 (0x0)
  GenMax Creation: 00/00/1900 00:00:00
         Shadowed: Yes
       Last Objid: 758
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 0
      Repair Date: 00/00/1900 00:00:00
 Old Repair Count: 0
  Last Consistent: (0x2F10,13F,77)  04/01/2014 09:40:53
      Last Attach: (0x2ECE,9,86)  03/29/2014 22:47:31
      Last Detach: (0x2F10,13F,77)  04/01/2014 09:40:53
             Dbid: 1
    Log Signature: Create time:06/21/2013 19:33:50 Rand:12799254 Computer:
       OS Version: (6.1.7601 SP 1 NLS ffffffff.ffffffff)

Previous Full Backup:
        Log Gen: 12021-12039 (0x2ef5-0x2f07) - OSSnapshot
           Mark: (0x2F08,8,16)
           Mark: 04/01/2014 01:32:38

Previous Incremental Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Copy Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Previous Differential Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Full Backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

Current Shadow copy backup:
        Log Gen: 0-0 (0x0-0x0)
           Mark: (0x0,0,0)
           Mark: 00/00/1900 00:00:00

     cpgUpgrade55Format: 0
    cpgUpgradeFreePages: 0
cpgUpgradeSpaceMapPages: 0

       ECC Fix Success Count: none
   Old ECC Fix Success Count: none
         ECC Fix Error Count: none
     Old ECC Fix Error Count: none
    Bad Checksum Error Count: none
Old bad Checksum Error Count: none

  Last checksum finish Date: 00/00/1900 00:00:00
Current checksum start Date: 00/00/1900 00:00:00
      Current checksum page: 0


Operation completed successfully in 0.62 seconds.
0
 
LVL 7

Author Comment

by:rpliner
ID: 39969603
in EMC, there are no mailboxes associated with the public folder database.
0
 
LVL 7

Accepted Solution

by:
rpliner earned 0 total points
ID: 39969886
I found these links which seem to provide the accepted method of dealing with this.

http://terenceluk.blogspot.com/2013/03/exchange-server-2010-mail-enabled.html

http://support.microsoft.com/kb/2487271/en-us

will update to confirm so others can use this info if they happen upon this.
0
 
LVL 7

Author Closing Comment

by:rpliner
ID: 39978625
it worked
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…
Suggested Courses
Course of the Month11 days, 9 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question