Solved

Ubuntu destop (screen) size, side ICONS of screen

Posted on 2014-04-01
  • Linux
  • Linux Distributions
  • Linux OS Dev
  • Displays / Monitors
  • Hardware
  • +1
57
752 Views
Last Modified: 2016-11-23
I have a NVIDIA GeForce 8400 GS video card and running Ubuntu 12.04.4 with all its updates. I use this same version on a laptop and do not have this problem but I also run it on a Dell Optiplex with on-board intel video and it has the same problem. What is the Problem? The sidebar and top menus are off screen. I don't know how I can use Linux system/video settings to shrink the size of the desktop to fit on my screen. The PC is connected to a Panasonic TV via HDMI (The Dell to a flat screen monitor via VGA). I have used all available screen resolution settings but none do the trick. I have used the "search for additional drivers" in Settings and tried both the recommended and the latest NVIDIA drivers but that does not help either. How do I (can I) reduce, shrink the size of my desktop, so the outer borders come in so the side bar and top menus can be seen? Thank you.
0
Comment
Question by:lionelmm
  • 26
  • 19
  • 8
  • +2
57 Comments
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Run nvidia-settings on any graphics screen and set resolution and output configuration you want.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
and how do I do that? there is no place in settings that are specific to nvidia, and if I do a search on nvidia from Dash Home nothing is found. thanks
0
 
LVL 35

Expert Comment

by:mccarl
Comment Utility
It's a bit hard to follow from your description of the problem, but would say then that this problem appears when connecting just to the Panasonic TV? It sounds like that would be the issue, as most TV are setup to "crop" the screen slightly as normal TV signals can (at least they used to) have crap araound the edges of the screen.

I connect my Linux PC via HDMI to my Samsung TV and I too had to adjust the TV to display the full picture (rather than cropping it). I don't have a Panasonic TV so I can't tell you where to find the settings, but just as example, my Samsung has this under Menu -> Picture -> Picture Size. Check out your setting and let us know how you go.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
You run any terminal program in graphics environment
Then type nvidia-settings
0
 
LVL 13

Expert Comment

by:Sandy
Comment Utility
nvidia-settings

this will fix the issue in resolution and screen size portion.

TY/SA
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Changing the setting on the TV does not work--tried it. This is a dual boot system, with XP and Ububtu--I hope to kill the XP boot. In XP nvdia display settings you can actually drag the screen edges in (resize the desktop), tell it where the parameters are -- I don't see this in Ubuntu. I did find the nvidia settings and it has a lot of additional resolutions--I tried all of them (8) and some will show the side bar and NONE make the top menu bar visible--NONE.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Would be nice to check spec sheet of your TV set to figure out pixel resolution.
Unless we get more information from your TV try these (last needs good cable):
https://en.wikipedia.org/wiki/High-definition_video#Common_high-definition_video_modes
There is no analog overscan in HDMI that needs corner adjustment like CRT TV
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Sandy/ screen size portion, where is that?
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
The problem persists and have received no further recommendations--can anyone help? Thinking of going back to Windows where this issue is easily fixed (at least it was in XP).
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
As has been mentioned before, we need more info. For example the exact model of your TV, so we can look up it's specifications. I also have some problems with what exactly your problem is. If possible post some screen shots of or make photo's of how it looks so we can get a better "grasp" of the issue.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
It is a Panasonic Viera TC-P60S30
http://service.us.panasonic.com/OPERMANPDF/TCP60S30.PDF
and there desktop is not contained in the screen borders--the top and bottom is below the screen borders and on the sides there is about an inch or two that is not used, like a dark useless border. Will try to get a picture to you and a screen shot that shows the missing top and bottom.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Here are pictures that should make the problem clear. As a reminder using the different screen format sizes (Full, 4:3, zoom, H-Fill, Just) do not fix this problem
Panasonic-Screen--Desktop-top-an.JPG
Panasonic-Screen--grey-edge-on-r.JPG
Panasonic-Screen--desktop-bottom.jpg
Panasonic-Screen--grey-edge-on-l.jpg
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Final One of the entire screen
Panasonic-Screen--big-picture.JPG
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
BUT you must use TV buttons to center picture. Sounds wierd and moot on digital tv, but panasonic likes analog tv reminders.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Native resolution of tv is 1920x1080
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
TV works just fine when a TV--this problem only appears when using it as a monitor. TV mode fine--problem when a monitor. I have tried ever possible resolution available to me through Ubuntu--every single one and there were a lot.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
According to guide you need to use TVs controls to center the full resolution (1920x1080) picture. All other sizes are expected to have black borders.
For full HD video i'd recommend getting nvidias driver right yesterday from driver manager in ubuntu.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
What resolution is selected, and which ones are available within "Display Settings/Displays"? inside a terminal enter xrandr and post the output.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Also post /var/log/Xorg.0.log (full file as attachment) for further study.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
PS I have similar setup and nvdia's proprietary driver DOES NOT WORK wirh 12.04.4
Please change kernel to
linux-generic (aka 12.04.0) or linux-generic-lts-trusty (aka 12.04.5 to be) (names of APT packages)
once new kernel is running remove lts-saucy and lts-raring packages if present.
also make sure you have dkms running if you attempt to install nvidia components again.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
gheist--All other sizes are expected to have black borders
The TV mode is fine--it works perfectly. In monitor mode I have tried all the resolutions available, all of them
Please change kernel to
OK all that is beyond me to do unless I get very specific and step by step instructions. As much as I love Ubuntu it sucks that something like this is so simple in Windows (simple drag corners and that's it).

Will get the other requested info to you tomorrow.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
we can hardly be helpful.it took month to cough up tv specs, now we just wait for another fot you to provide system information.
You see there is no need to change the tires if you have porato in exhaust pipe...
We are looking for various bits of your system info:
Is it 32bit or 64bit
Exact kernel version
If you attempted nvidia install and IF it went well
Does your current hardware driver claims to support native resolution of your TV..
Also if you have HDMI 1.0 cable 1920x1080 will not have enough bandwidth for RGB...

See there are many variables that your system info files can help with
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Actually I waited for a month to get a response from http://www.experts-exchange.com/OS/Linux/Q_28402291.html#a39976043. As far as waiting another day goes I apologize that this is such a huge inconvenience to you and fully understand if you prefer to no longer give any help--thanks for what you have suggested thus far and good luck to you--have a great day.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
If you wait now for christmas good luck, otherwise provide at least some system information...
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Apologies for delay--fell out of chair had a 2 day concussion--still a bit foggy-excuse
gheist: Native resolution of 1920x1080 = menu's on side and top missing
gheist: getting nvidias driver right yesterday from driver manager in ubuntu. -- this is how nvidia was installed & File requested attached

rindi: xrandr and post the output
Screen 0: minimum 8 x 8, current 1680 x 1050, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 698mm x 392mm
   1920x1080      60.0*+   59.9     24.0     60.1     60.0  
   1440x480       60.1  
   1280x720       60.0     59.9  
   720x480        59.9     60.1  
   640x480        59.9
Xorg.0.log
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Both outputs agree that native resolution of your HDMI TV is 1680x1050 (sorry for that)

[    14.063] (**) NVIDIA(0): Option "MetaModes" "nvidia-auto-select +0+0 {viewportin=1680x1050, viewportout=1728x1080+96+0}"
[    14.063] (**) NVIDIA(0): Enabling 2D acceleration
[    14.728] (II) NVIDIA(0): Display (PanasonicTV0 (DFP-1)) does not support NVIDIA 3D

Open in new window


Try that via nvidia-settings... First vertical fit, then horizontal.

Even more advisable to use manual resolution because your TV has incomplete ID data (if there is TV firmware upgrade - do it)
[    14.785] (WW) NVIDIA(0): PanasonicTV0 (DFP-1)'s EDID does not contain a maximum image
[    14.785] (WW) NVIDIA(0):     size; cannot compute DPI from PanasonicTV0 (DFP-1)'s
[    14.785] (WW) NVIDIA(0):     EDID.

Open in new window

Your kernel 3.11.0-19-generic cannot accomodate drivers from nvidia's website. No big problem since ubuntu shipped driver worked out just fine.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
Both outputs agree that native resolution of your HDMI TV is 1680x1050 (sorry for that)
This is the resolution I choose--the one that shows most of the side but still none of the top menu. I can switch to the 1920x1080 resolution -- and I was able to install drivers from NVIDIA -- I am not using the native ones that came with Ubuntu and the NVIDIA options are much better than the native driver options.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Since you figured out you have 1050px vertically now try bigger and smaller horizontal resolutions until you get it rigt.
e.g. my philips TV (fairly old) says via EDID it is 1366 pixels horizontally, but if you use 1366 it shows center of the display upscaled. If I go 1360px picture appears normal.
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 24

Author Comment

by:lionelmm
Comment Utility
how do I adjust them independently--I have no idea how to do that?
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Nvidia Settings has all resolutions detected
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
So, what does that mean--does not allow me to adjust horizontal and vertical independently. No matter which one of the provided resolutions I choose the desktop does not fit onto the screen. In Windows I can independently drag and drop corners and sides and top or bottom. This very easy thing in Windows is a pain in Ubuntu--makes me want to go back to Windows reluctantly.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
It will have couple of horizontal resolutions at 1050 vertical to choose from
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
where is this--I see no place where this can be done independently; please ay where to find this--this is now the 3rd time I have said I don't know where to go to adjust vertical and horizontal independently.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Simple goole search brought me to this screenshot:
http://www.ypass.net/blog/wp-content/uploads/2010/04/Screenshot-NVIDIA-X-Server-Settings.png

text on shortcut is "Nvidia Settings Applet" and command invoked is nvidia-settings.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
I will close this question in the next day or two--want to post a screen shot to show how I was able to resolve the issue for anyone else who has a similar problem.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
no matter what I try this will not work--tried your suggestions--tried many others from youtube. I have got to the point where I can get it to be exactly what I want but then after a reboot it just will not stay the same. I have saved it to the x config file (after reboot the same); have not saved it (after reboot the same). Undersan always comes back to 43 and needs to be around 57 to 67
Nvidia-X-Server-Settings.png
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Because you need to "save X vonfiguration file" to make any changes permanent (and be the user who can save that, like root)
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
in my previous comment I said " I have saved it to the x config file" and it did not work. so, I did that, and I said that I did that so telling me do something that I already tried is not working. It ask for a password to change it and it saves it (it does not report an error) and the user that I am doing this with the the user that was used to install and setup ubuntu, namely this is the only user there is.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
That is not what I have posted about above. running xrandr doesn't need any password, it can be run directly from the logged on user. You only need the password to delete the xorg.conf file I mentioned above. That file should be deleted because it tends to get in the way of xrandr.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
If you look at the picture I posted there is a box to "save" the changes--the changes that I want remembered and when i click on that box it asks for a password and behaves as if it is saving but then on reboot it is back to what is was before.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Try running it with gksu i.e
"gksu nvidia-settings"
 (it works for me, but ok maybe way you have it nvidia-settings cannot make privileged calls)
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
That's the nvidia utility. Don't use that. It creates an xorg.conf file, and that is not what you want to use.

You should rather delete the xorg.conf file and use xrandr instead of the nvidia utility to setup the displays. And once you have the settings that work best, you can put those xrandr commands into a script which you just need to execute when you need the settings.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
I want the settings to stay the same all the time, every time I reboot, every time I use it so please give me step for step instructions on how to do that--I do not need more than one video settings--just one.
0
 
LVL 61

Assisted Solution

by:gheist
gheist earned 125 total points
Comment Utility
sudo dpkg-reconfigure xserver-sxorg

will delete xorg.conf (or generate good one on older distributions)
0
 
LVL 87

Assisted Solution

by:rindi
rindi earned 375 total points
Comment Utility
Delete the /etc/X11/xorg.conf file.

Then use gtf to get the necessary values for the resolutions for your display, for example if your TV supports 1280 x 768 at 60 Hz (like mine does), enter:

gtf 1280 768 60

This will display a bunch of numbers, like this:

gtf 1280 768 60

  # 1280x768 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
  Modeline "1280x768_60.00"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync

Then use xrandr to create a new mode with those values, like this:

xrandr --newmode 1280x768_60 83.46 1280 1344 1480 1680 800 801 804 828 -HSync +Vsync

The "1280x768_60" after the newmode is the name or label for that new mode, and the calues behind that are the values you saw with the gtf command, after the "Modeline "1280x768_60.00"" part.

After that you need to add that mode you just created to the output your TV is connected to, for example like this:

xrandr --addmode HDMI-0 1280x768_60

Now you have to use that mode with the following command:

xrandr --output HDMI-0 --mode 1280x768_60

You can try out different resolutions that way. As was mentioned earlier, some TV's can't use the full resolution when using an external input (My TV has a resolution of 1366x768 for the built-in TV tuner, but whatever is connected via the HDMI ports can only use a resolution of 1280x768), so you may have to try out resolutions that are a little lower then your TV's resolution to get the correct setting.

Once you have found the best setting for your TV or display that way, you can store the xrandr commands into a script, for example like the one I've attached, and then just execute that script after logging on to Ubuntu. You can also make Ubuntu run that script automatically when you login via the "Startup Application" utility (just search for startup), then clicking on "Add".
resolution.sh
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
@gheist--I get this error when I tried your suggestion
ubuntu-tv:~$  sudo dpkg-reconfigure xserver-sxorg
[sudo] password for lmm:
Package `xserver-sxorg' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: xserver-sxorg is not installed
ubuntu-tv:~$
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
@rindi--says I can't delete /etc/X11/xorg.conf file--not owner or root. then I tried the other commands you suggested and got an error
root@ubuntu-tv:/home/lmm# gtf 1920 1080 60
# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

root@ubuntu-tv:/home/lmm# xrandr --newmode 1920x1080_60.00 172.80 1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
root@ubuntu-tv:/home/lmm# xrandr --addmode HDMI-0 1280x1080_60
xrandr: cannot find mode "1280x1080_60"
root@ubuntu-tv:/home/lmm#
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
My bad - package name is xserver-xorg

In the rindi's front:
Do you see two zeroes _60.00 where i see them?
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
xorg.conf is a system file, so you need to use sudo to delete or rename it.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
gheist--I have no idea what you trying to say about "In the rindi's front: Do you see two zeroes _60.00 where i see them?"
0
 
LVL 87

Assisted Solution

by:rindi
rindi earned 375 total points
Comment Utility
In your xrandr --newmode statement above, you used the following:

root@ubuntu-tv:/home/lmm# xrandr --newmode 1920x1080_60.00 172.80 1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

You named the newmode "1920x1080_60.00"

(with a decimal point and 2 zeroes after that). In your later "--addmode" statement you left out that decimal point and the 2 zeroes. So the system can't find that mode. You either have to use the decimal and the 2 zeroes in both statements, or leave it out in both statements.

You can also use xrandr --help to get more help on the xrandr syntax and how you can use it.
0
 
LVL 35

Expert Comment

by:mccarl
Comment Utility
That's not the only difference, in the "--newmode" line you used 1920.... And then in the "--addmode" line you used 1280....     Whatever it is doesn't really matter just that it needs to be the same in both.
0
 
LVL 24

Author Comment

by:lionelmm
Comment Utility
I am totally lost with all this. If someone will give me just plain and simple instructions--I keep getting or permissions errors. I am a fairly newbie to linux and unbuntu. If you tell me every single step, step 1 do this and then this without assuming I know anything or where anything is because in most cases I don't. I did try to follow what rindi and mccari said but just can't seem to get the changes to stay from one boot to the next.
0
 
LVL 87

Assisted Solution

by:rindi
rindi earned 375 total points
Comment Utility
xrandr can be run without elevated privileges but the /etc/X11/xorg.conf file will have to be deleted or moved using sudo before the command, you will then have to enter your password. For anything that requires elevated privileges use sudo before your commands.

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.cong.backup

would rename the xorg.conf file to xorg.conf.backup instead of deleting it.
0
 
LVL 24

Accepted Solution

by:
lionelmm earned 0 total points
Comment Utility
I just got so tired of all the suggestion and all the recommendations that were less than complete--that required that I go do additional research on my own. Suffice it to say that with all the suggestions given I still do not have a fixed screen BUT AT LEAST I am able to see the side bar and menu on top so it is  step forward. I will still more than likely go back to Windows on this PC because of this video issue. Regardless of my complaints about the advice give I want to say thank you because I am sure it was also not easy for the experts to deal with me as a linux newbie who really need precise and complete instructions.
0
 
LVL 24

Author Closing Comment

by:lionelmm
Comment Utility
too much incomplete instructions
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now