• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 233
  • Last Modified:

Why are disconnected users forced to logon twice in 2008 R2 RD farm?

I have eight 2008 R2 session host servers and one  R2 broker configured to participate in my farm. I am allowing disconnected sessions for 10 minutes however when a client attempts to reconnect to their disconnected session they are forced to enter their logon credentials twice. As a very busy hospital allowing disconnected sessions is very beneficial to several departments but this is frustrating staff. Any ideas??
0
sysengineer
Asked:
sysengineer
  • 2
1 Solution
 
Lionel MMSmall Business IT ConsultantCommented:
How are the connecting to your server, via VPN, local LAN or ??? Is their any similarity in those who have to logon twice, same OS, from the same location or is it happening to everyone?
0
 
MaheshArchitectCommented:
you have to use single sign on in order to avoid double login prompt

For XP you need to enter below registry keys manually and have to have Windows XP SP3
http://support.microsoft.com/kb/951608

Also you need to apply KB953760 on XP SP3 machines
http://support.microsoft.com/kb/953760

On Windows 7 below settings to be done
http://blogs.msdn.com/b/rds/archive/2007/04/19/how-to-enable-single-sign-on-for-my-terminal-server-connections.aspx

Mahesh.
0
 
sysengineerAuthor Commented:
I changed the log on settings in RDP connection properties to use client-provided log on information. I also noticed the broker was not configured for dedicated farm redirection. That seems to have resolved the problem.
0
 
sysengineerAuthor Commented:
Because it resolved the problem.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now