[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

BGP Network Advertising

Posted on 2014-04-02
3
Medium Priority
?
390 Views
Last Modified: 2016-11-23
I have network behind core switch is 192.168.10.0/25
and my routing to corporate network is BGP routing. I published my network at BGP as 192.168.10.0/24 because we have other subnet that also using 192.168.10.241/28 that doing routing internally.

at Corp router, they only allowed our subnet advertise as /24.
all my server which is using /25 subnet is not able to reach the next hop at Corp. which according to them they can't find my subnet advertised at their route table.
if to ask them change to accept my subnet which is /25 required a lot of process and paper work and question that to answer to justify it. the flow may take longer.

i understand that auto summarization may help... but i seem can't find the command in my switch.

By the way, I'm using Dell Force10 S4810. all this works perfectly until the host subnet been requested to change to /25

tks
0
Comment
Question by:hell_angel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 17

Accepted Solution

by:
pergr earned 1500 total points
ID: 39974135
Most likely the issue is that in order to advertise a /24 route in BGP, you first must have that /24 route in your routing table.

You typically do that by setting a static route for the /24, with next-hop as "null0" or "discard", or what ever the vendor software will call it.

Once that is done, the /24 will be advertised and the Corp should see it.
0
 

Author Comment

by:hell_angel
ID: 39974234
it solved.

added ip route to null and aggregate -address
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 39975745
For your router to advertise the BGP route of 192.168.10.0/24, you need to have that route in your internal routing table already. What you want to do is correct though.

The solution is to put a static route in your BGP router:
ip route 192.168.10.0 255.255.255.0 null0

This will allow your router to advertise that route in BGP. Because routers always route to the most specific route, your existing routes will continue to work. Any traffic sent to a /24 destination that doesn't actually exist will simply be dropped.
0

Featured Post

Q2 2017 - Latest Malware & Internet Attacks

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out our latest Quarterly Internet Security Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Getting to know the threat landscape in which DDoS has evolved, and making the right choice to get ourselves geared up to defend against  DDoS attacks effectively. Get the necessary preparation works done and focus on Doing the First Things Right.
A new hacking trick has emerged leveraging your own helpdesk or support ticketing tools as an easy way to distribute malware.
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question