• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 788
  • Last Modified:

F5 Load Balancer - Active/Standy switching role controlling failover

Running 2 F5 load balancers in a Active/Standby role, running version 10.2.1.
Although in a normal failover scenario it works fine but, recently within the data centre they are hosted, there was a power issue and the Active lost power. The standby took control as expected. They use the serial connection to advertise each other. So, the power on the original Active was restored then  lost a few times ,with the switch it was connected also not available. The result being, all connections were being sent to the Active which had no switch to send connections to or receive so causing timeout for traffic.

So, how do I in this scenario stop the "active" device on having power restored stop becoming the ACTIVE load balancer . Actual fail back needing a manual fail back not automated as in a Cisco ASA active/failover scenario.
0
ccfcfc
Asked:
ccfcfc
  • 4
  • 4
1 Solution
 
giltjrCommented:
You need to change the preferred HA state to none on both F5's.

However you should setup a fail over check that would detect the F5 not having a valid path.  Depending on your setup defining a fail-safe gateway pool should work.
0
 
ccfcfcAuthor Commented:
Sounds a good plan but, as soon as you put one of the devices Redundancy State Preference to NONE both devices start to become "active" . So not sure if you have the steps to stop this actvity.  So LB-01 is in Active/Standby and currently set to Active and LB-01 set to Standby. What ever way I change state Preference to "NONE" they start to fight for Active role.
In principle it seems it should work as, if the Active ever fails and control goes to the Standby you dont want the original Active to take control until you do a manual fail back. It seems I cant get them to operate in an active/standby mode when I change the Redundancy State Preference on either box.
If that makes sense.
0
 
giltjrCommented:
--> Sounds a good plan but, as soon as you put one of the devices Redundancy State Preference to NONE both devices start to become "active"

Then there is a configuration issue someplace.

Do you have Fail Safe VLAN's or Gateways configured?

Have you loaded your config in F5's iHeath?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ccfcfcAuthor Commented:
No we do not as we use the serial connector for detecting physicsl failure. Based on geography and the network setup this was seen as the best method opposed to setting up a VLSN to detect for any errors or issues.
0
 
giltjrCommented:
The serial connection will only help detect a full failure of a F5.  This will not help if you lose a network path between the F5 and another network device.

Do you have two diverse physical (L2) connections from each F5 to different network devices for each logical (L3) network?
0
 
ccfcfcAuthor Commented:
No, I was told by F5 direct that whereas you can put diverse conenctions it, this is not a good idea and or possible with a physical 1600. Perhaps this has changed with v11 of the software. I have a single 1 to 1 L2 link between F5 and switch for traffic by L3.
0
 
giltjrCommented:
You need to use either Fail Safe VLAN's or Gateways or both depending on your setup.
0
 
ccfcfcAuthor Commented:
ok I shall look into it
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now