Enabling Firewall through GPO

I have a Small Business Server 2008. I have found that the firewall is turned off on all the workstations. When I choose to enable the firewall I get a message that the firewall settings are managed through Group Policy.

To enable the Firewall from the server, I opened Group Policy Management and did the following:
Under the domain name I did a right click and edit on "Default Domain Policy"
I then navigated to:
Computer Configuration -> Policies -> Windows Settings -> Windows Firewall with Advanced Security -> Windows Firewall with Advanced Security - LDAP://CN={GUID}, CN=Policies,CN=System,DC=Company,DC=Local

In here I found the firewall turned off. I enabled this and left the Link Enabled and Enforced disabled. I waited 1 hour then I went to a workstation and did a gpupdate /force.

The Firewall still shows off on the workstation.
What did I miss? Should the firewall be set somewhere else?
Who is Participating?
Cliff GaliherConnect With a Mentor Commented:
Editing the default domain policy is usually a bad idea. SBS creates a separate firewall policy by default and link order is also (by default) set so it takes precedence. That ahoild be the policy you edit.

But a few points that will generically help you:

The default refresh time for GPOs is 90 minutes, which is longer than the hour you waited.

Gpudate is your friend. If you can't wait the full refresh time, this can produce near immediate results.

The GP results wizard in GPMC can produce the "final" list of all settings for a particular user on particular workstation. It will also tell you *which* GPO each setting is coming from. You can and should run this so you know which policy is causing a setting to appear (including why the firewall is off.) it saves you from hunting and guessing.
LostInWindowsAuthor Commented:
Thanks for this information. Do you know where SBS sets up its default firewall policy? I should check it and see if it is enabled.
Cliff GaliherCommented:
It is a clearly named group policy. SBS firewall policy or similarly named.
LostInWindowsAuthor Commented:
Thank you, It is fixed now!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.