?
Solved

Wordpress index.php URL

Posted on 2014-04-03
10
Medium Priority
?
442 Views
Last Modified: 2014-04-30
Hi, i have just installed a new copy of wordpress on my site, however i have noticed that all of my urls have 'index.php' - such as

http://mywebsite.com/index.php/about-us/
http://mywebsite.com/index.php/contact-us/
http://mywebsite.com/index.php/news/

etc...

Does anyone know how to stop this? Thanks in advance...
0
Comment
Question by:oo7ml
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 18

Assisted Solution

by:Emmanuel Adebayo
Emmanuel Adebayo earned 200 total points
ID: 39974404
Check the general settings in the Admin section.

Also check the theme that you are using if it has "home page" section.

Regards
0
 
LVL 58

Assisted Solution

by:Julian Hansen
Julian Hansen earned 200 total points
ID: 39974446
Have you read the wordpress article on Using Permalinks? You might find your answer there

http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks
0
 

Author Comment

by:oo7ml
ID: 39974516
Thanks, i just read that but it's a little over my head...
0
WordPress Tutorial 3: Plugins, Themes, and Widgets

The three most common changes you will make to your website involve the look (themes), the functionality (plugins), and modular elements (widgets).

In this article we will briefly define each again, and give you directions on how to install them.

 
LVL 14

Expert Comment

by:John-Charles-Herzberg
ID: 39974681
Can you have a look at the control panel (Left side) under permalink setting and change it to "Default"

Permalink Settings
Thanks
JC
0
 

Author Comment

by:oo7ml
ID: 39974711
Hi, i changed it back to default but now i obviously don't have the 'pretty urls'

permalinks
0
 
LVL 14

Expert Comment

by:John-Charles-Herzberg
ID: 39974739
Can you tell me what was it set on before you changed it to default?  Was it "Custom Structure" with "/index.php/%postname%/"

Was Wordpress installed in a folder called "index.php"  if so you might have to change the folder name

Thanks
JC
0
 

Author Comment

by:oo7ml
ID: 39975044
It wasn't installed in any folder called index.php and i had it previously set to 'Post Name'
0
 
LVL 14

Expert Comment

by:John-Charles-Herzberg
ID: 39975058
Who is your hosting provider?  Can you send a screen shot of the directory structure?

Thanks
JC
0
 

Author Comment

by:oo7ml
ID: 39975068
register365.com

the files are placed in web... attached is the root directory

file
0
 
LVL 14

Accepted Solution

by:
John-Charles-Herzberg earned 1600 total points
ID: 39975400
This is a good post that might help.  It look to be a hosting problem,

http://derekmolloy.ie/remove-index-php-from-your-wordpress-url/

Remove index.php from your WordPress URL

You will notice in this site which runs using WordPress that there is no index.php in the URL when you are directly addressing a page/post or when you are linking to other pages/posts.

There are two step 1's, depending whether you/your web provider is using Apache or Zeus scripting.


or this one


http://www.niallflynn.com/seo-news/register-365-wordpress-permalinks/

I ran into an issue today, while optimising a WordPress site hosted on Register 365 Servers, which initially looked to be Apache, but on closer inspection was Zeus. Not to worry I thought, WordPress will sort all this out, it’s an Apache type web server, I am sure the .htaccess will work. Well it did not and after a long time searching and looking around I found this work around.

No .htaccess instead rewrite.script, the code for the rewite.script is below and you can also download a zipped copy of the file here;


Thanks
JC
0

Featured Post

WordPress Tutorial 1: Installation & Setup

WordPress is a very popular option for running your web site and can be used to get your content online quickly for the world to see. This guide will walk you through installing the WordPress server software and the initial setup process.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Did you use a default hosting installation of wordpress with the intention of it being your actual site?  Maybe you’ve installed it as a Blog to your current site and recently converted it to be the main site and do away with the old .htm pages.  An…
This article shows the steps required to install WordPress on Azure. Web Apps, Mobile Apps, API Apps, or Functions, in Azure all these run in an App Service plan. WordPress is no exception and requires an App Service Plan and Database to install
The purpose of this video is to demonstrate how to insert an Iframe into WordPress. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Open Page or Post…
The purpose of this video is to demonstrate how to Import and export files in WordPress. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Click on Too…
Suggested Courses
Course of the Month9 days, 16 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question