Solved

Cisco ASA memory failure

Posted on 2014-04-03
7
1,436 Views
Last Modified: 2014-04-03
I have a ASA5510 running 8.0.5 which has 256Mb memory. To upgrade it to the later 8.3+ firmware i have just tried to replace the 256Mb memory with 1Gb memory stick.
The ASA is now in a boot loop.

The things tried so far....

Putting the 256Mb memory stick back in - same result (boot loop)
Putting in a 1Gb memory stick from a second working ASA5510 - same result (boot loop)
Putting the new (suspect) 1Gb memory stick in the second working ASA - boots up fine.

This makes me believe there is no problem with the memory

I suspect the ASA is now defective but as the unit has no TAC support,  this forum is the last chance before giving up.

I have booted the unit using TFTP and the output is below also the various commands i've tried (i done this with both 256Mb and 8.0.5  image and also 1Gb and 8.3 image the results are the same).

Any further ideas gratefully received...........



Booting system, please wait...


CISCO SYSTEMS
Embedded BIOS Version 1.0(11)2 01/25/06 13:21:26.17

Low Memory: 631 KB
High Memory: 256 MB
PCI Device Table.
Bus Dev Func VendID DevID Class              Irq
 00  00  00   8086   2578  Host Bridge
 00  01  00   8086   2579  PCI-to-PCI Bridge
 00  03  00   8086   257B  PCI-to-PCI Bridge
 00  1C  00   8086   25AE  PCI-to-PCI Bridge
 00  1D  00   8086   25A9  Serial Bus         11
 00  1D  01   8086   25AA  Serial Bus         10
 00  1D  04   8086   25AB  System
 00  1D  05   8086   25AC  IRQ Controller
 00  1D  07   8086   25AD  Serial Bus         9
 00  1E  00   8086   244E  PCI-to-PCI Bridge
 00  1F  00   8086   25A1  ISA Bridge
 00  1F  02   8086   25A3  IDE Controller     11
 00  1F  03   8086   25A4  Serial Bus         5
 00  1F  05   8086   25A6  Audio              5
 02  01  00   8086   1075  Ethernet           11
 03  01  00   177D   0003  Encrypt/Decrypt    9
 03  02  00   8086   1079  Ethernet           9
 03  02  01   8086   1079  Ethernet           9
 03  03  00   8086   1079  Ethernet           9
 03  03  01   8086   1079  Ethernet           9
 04  02  00   8086   1209  Ethernet           11
 04  03  00   8086   1209  Ethernet           5

Evaluating BIOS Options ...
Launch BIOS Extension to setup ROMMON

Cisco Systems ROMMON Version (1.0(11)2) #0: Thu Jan 26 10:43:08 PST 2006

Platform ASA5510

Use BREAK or ESC to interrupt boot.
Use SPACE to begin boot immediately.

Launching BootLoader...
Default configuration file contains 1 entry.

Searching / for images to boot.

No images in /
Error 15: File not found

unable to boot an image


Default configuration file contains 1 entry.

Searching / for images to boot.

No images in /
Error 15: File not found

unable to boot an image


Failsafe booting engaged.
Default configuration file contains 1 entry.

Searching / for images to boot.

No images in /
Error 15: File not found

unable to boot an image

Booting system, please wait...

----------------------------------------------------------------------------------------------------------------------

Launching TFTP Image...

Cisco Security Appliance admin loader (3.0) #0: Mon Nov  2 21:27:21 MST 2009
Loading...
mount: mounting /dev/hda1 on /mnt/disk0 failed
mount: mounting /dev/hda1 on /mnt/disk0 failed

Processor memory 177901568, Reserved memory: 20971520 (DSOs: 0 + kernel: 20971520)
Guest RAM start: 0xd4000080
Guest RAM   end: 0xdd400000
Guest RAM   brk: 0xd4001000

IO memory 51224576 bytes
IO memory start: 0xd0bff000
IO memory   end: 0xd3cd9000

Total SSMs found: 0

Total NICs found: 7
mcwa i82557 Ethernet at irq 11  MAC: 001e.be79.7604
mcwa i82557 Ethernet at irq  5  MAC: 0000.0001.0001
Internal error. Crash dump information may not be read or written to flash
i82546GB rev03 Ethernet @ irq09 dev 3 index 00 MAC: 001e.be79.7600
i82546GB rev03 Ethernet @ irq09 dev 3 index 01 MAC: 001e.be79.7601
i82546GB rev03 Ethernet @ irq09 dev 2 index 02 MAC: 001e.be79.7602
i82546GB rev03 Ethernet @ irq09 dev 2 index 03 MAC: 001e.be79.7603
i82547GI rev00 Gigabit Ethernet @ irq11 dev 1 index 05 MAC: 0000.0001.0002

INFO: Unable to read firewall mode from flash
       Writing default firewall mode (single) to flash
Running Activation Key: 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000

This activation key is not valid, use default settings only

Encryption hardware device : Cisco ASA-55x0 on-board accelerator (revision 0x0)
                             Boot microcode   : CN1000-MC-BOOT-2.00
                             SSL/IKE microcode: CNLite-MC-SSLm-PLUS-2.03
                             IPSec microcode  : CNlite-MC-IPSECm-MAIN-2.05

Cisco Adaptive Security Appliance Software Version 8.0(5)

  ****************************** Warning *******************************
  This product contains cryptographic features and is
  subject to United States and local country laws
  governing, import, export, transfer, and use.
  Delivery of Cisco cryptographic products does not
  imply third-party authority to import, export,
  distribute, or use encryption. Importers, exporters,
  distributors and users are responsible for compliance
  with U.S. and local country laws. By using this
  product you agree to comply with applicable laws and
  regulations. If you are unable to comply with U.S.
  and local laws, return the enclosed items immediately.

  A summary of U.S. laws governing Cisco cryptographic
  products may be found at:
  http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

  If you require further assistance please contact us by
  sending email to export@cisco.com.
  ******************************* Warning *******************************

Copyright (c) 1996-2009 by Cisco Systems, Inc.

                Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

                Cisco Systems, Inc.
                170 West Tasman Drive
                San Jose, California 95134-1706

Insufficient flash space available for this request:
  Size info: request:32 free:0  delta:32
open or write(ffsdev/2/write/32) failed
Could not initialize system files in flash.
Type help or '?' for a list of available commands.
ciscoasa>


------------------------------------------------------------------------------------------------------------------------


ciscoasa# fsck flash:
Unsupported file system type!

%Error checking flash: (No such device)

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# fsck disk0:
Unsupported file system type!

%Error checking disk0: ()

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# fsck disk1:

%Error checking disk1: ()

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# erase flash:
WARNING: Saving activation key file failed. Proceed with operation? [confirm]

Erase operation may take a while. Continue? [confirm]

Erasing the disk0 filesystem will remove all files! Continue? [confirm]

%Error erasing disk0: (No such file or directory)
ciscoasa#

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# wr mem
Building configuration...
Cryptochecksum: 881c36e4 22d16c1d 25aa344c 3ed274c7

%Error copying system:/running-config (Not enough space on device)
Error executing command
[FAILED]
ciscoasa#

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# dir disk1:/

%Error opening disk1:/ (No such device)

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# dir disk0:/

Directory of disk0:/

1164   -rw-  196         09:39:27 Apr 03 2014  upgrade_startup_errors_201404030939.log
1162   drw-  0           09:39:27 Apr 03 2014  coredumpinfo
1157   drw-  0           09:39:25 Apr 03 2014  crypto_archive
1147   drwx  0           09:39:17 Apr 03 2014  log

0 bytes total (0 bytes free)

---------------------------------------------------------------------------------------------------------------------------

ciscoasa# format disk0:

Format operation may take a while. Continue? [confirm]

Format operation will destroy all data in "disk0:".  Continue? [confirm]

%Error formatting disk0 (No such file or directory)
ciscoasa#
0
Comment
Question by:nappyshock
  • 4
  • 3
7 Comments
 
LVL 51

Expert Comment

by:Netman66
Comment Utility
Looks like your flash memory is bad or the flash controller has failed.

Do you have an external flash card you could insert in the front to test if it works?
0
 

Author Comment

by:nappyshock
Comment Utility
Yes it has one in it, it is acting exactly the same as the internal flash.

When you try to access it.....

ciscoasa# dir disk1:/

%Error opening disk1:/ (No such device)


This external flash is from a working ASA.
0
 
LVL 51

Expert Comment

by:Netman66
Comment Utility
I had a 2600 router do exactly the same thing. Time to open a TAC case and have it replaced.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:nappyshock
Comment Utility
If only i could, it's not covered.

I think it's a gonna!
0
 
LVL 51

Accepted Solution

by:
Netman66 earned 500 total points
Comment Utility
Cisco may have a refurb program. You should look into that first, given the cost.
0
 

Author Closing Comment

by:nappyshock
Comment Utility
Thanks for your help
0
 
LVL 51

Expert Comment

by:Netman66
Comment Utility
Any time. Good luck, I hope Cisco can help you out. There may be a SmartNet SKU you can purchase for the 5510 and after a small wait call for warranty. Either way, Cisco usually stands behind their product and should be able to help.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Many companies are looking to get out of the datacenter business and to services like Microsoft Azure to provide Infrastructure as a Service (IaaS) solutions for legacy client server workloads, rather than continuing to make capital investments in h…
Nothing in an HTTP request can be trusted, including HTTP headers and form data.  A form token is a tool that can be used to guard against request forgeries (CSRF).  This article shows an improved approach to form tokens, making it more difficult to…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now