Solved

Exchange 2013 SP1 - Event Error Code 6003 - Unable to access path for logs

Posted on 2014-04-03
12
1,783 Views
Last Modified: 2014-05-02
Folks:

I have been searching Experts Exchange and the Web about this error and everyone says to add it to the "Environment Variable" but doesn't tell you where to add the path.

I am getting this error over and over in my Event Viewer:

SmtpSendProtocolLogs: Failed to create the log directory: E:\Mailbox Database Logs\Company\Protocol Log\Send because of the error: Access to the path 'E:\Mailbox Database Logs\' is denied.. Logs will not be generated until the problem is corrected.

For pretty much everything that is going to this location (regardless if it is a Protocol Log or not, it is showing up in the Event Viewer.

So I need to ask where do you I add all of these variables for these logs?
What type of permission should these folders have so that Exchange can write to them?
0
Comment
Question by:JustinBMak
12 Comments
 
LVL 36

Expert Comment

by:Mahesh
ID: 39976230
Since the path mentioned above is not default one, you need to create folder manually at above location

That will help hopefully

Mahesh.
0
 

Author Comment

by:JustinBMak
ID: 39976289
Mahesh:

The location is created. I created everything BEFORE making the changes via PowerShell.

window to show the folder is already and has been created
0
 
LVL 39

Expert Comment

by:Adam Brown
ID: 39976303
The Exchange Servers AD group would need to be granted read and write permissions on the folder if it isn't already located on an Exchange server, and possibly if it is (since those logs may be written by another exchange server).
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:JustinBMak
ID: 39976368
I have checked and the AD Group called "Exchange Servers" has Read/Write access at the root (Mailbox Database Logs) and the children below are set to get their permission from the parent.

Any other thoughts/ideas?
0
 
LVL 19

Expert Comment

by:R--R
ID: 39976838
Are you able to create a directory and try to create a file under the directory.
Verify if you have organization management permission for the user from which you are upgrading SP1.

reference link http://technet.microsoft.com/en-us/library/dd638213.aspx
0
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 39977141
http://technet.microsoft.com/en-us/library/cc727009(v=ws.10).aspx

and may have to fixed by Microsoft Tech support.
0
 

Author Comment

by:JustinBMak
ID: 39977993
R--R:

Yes, I can create a file in the directory:

Creating a file in that directory.
0
 

Author Comment

by:JustinBMak
ID: 39978004
Md. Mojahid:

I did contact Microsoft, they suggested that "Authenticated Users" has Read/Write access to the folders.

So I added that right yesterday (last night) and still today I see:
Which is why I am turning to Experts-Exchange for assistance.

Event Error 6003 - Exchange 2013
0
 
LVL 36

Expert Comment

by:Mahesh
ID: 39978021
Can you please try by changing log location to some else location \ Drive ?
0
 

Author Comment

by:JustinBMak
ID: 39978058
Mahesh:

I have moved it over to the "C:\" Drive and waiting for any errors, which generally take an hour.

I will post if it continues to happen.
0
 

Author Comment

by:JustinBMak
ID: 39985861
So of course it works just fine. I have checked the permissions between the folder on where it WAS (C:\Temp) to where I wanted it to be, I didn't see a difference. So I moved the folder (again) because C: only have a 40GB Partition and then (just for the heck of it) added "Everyone" to the Security ACL and now Exchange writes to the folder.

Obviously this isn't best practice, so does any one have any other ideas on what the permissions should be? I have contacted Microsoft and they say to add the security group "Authenticated Users" however the guy I spoke to that was on the phone was helping me on a different issue and honestly didn't know the answer to my question. So since it didn't work, it's obviously something else.

Does anyone else have any other idea?
0
 
LVL 36

Accepted Solution

by:
Mahesh earned 500 total points
ID: 39985926
If everyone group causing your custom path is working, its not good

Instead please try below

Grant system account and Exchange Servers group full control on folder (I hope its already there) and grant folder ownership to Exchange servers group and then try

Mahesh.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question