No more Windows 7 Gadgets.

For no particular apparent reason, or having done nothing to system outside of normal Windows Updates, my Gadgets stopped displaying on desktop. Here are the observations:

1. When I right click the desktop, I am unable to uncheck the Gadgets selection.

2. When I right click the desktop, and click the "view" dialog, I am UNABLE to UNCHECK "Show desktop gadgets".

3. When I go to the CONTROL PANEL and select "Appearance and Personalization", I am UNABLE to select any choices under "Desktop Gadgets". Clicking on these are totally UNRESPONSIVE. Only the "Get more gadgets online" will launch the web browser to the web page that says gadgets are no long available in Windows 8.

Virus scanning and spyware scanning show nothing.
RayRiderAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jcimarronConnect With a Mentor Commented:
RayRider--
Note MS offered this advisory almost two years ago
http://technet.microsoft.com/en-us/security/advisory/2719662

I'm just guessing that if you did not disable the Gadgets back then, some recent Update must have done it for you.
0
 
jerseysamConnect With a Mentor Commented:
Make sure UAC is NOT on
0
 
RayRiderAuthor Commented:
UNC is set one step below the default setting. This the level setting. Is there another setting to turn it totally Off? If so, how do I do that?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Gadgets are gone and yes, not available on my Windows 8 machine.

So probably the best approach is to forget them.

If you want them, try running System File Checker. Open an admin command prompt, and run SFC /SCANNOW and allow to complete. Restart the computer and test.

You might also consider scanning completely for malware and viruses.

I did not have to turn UAC off to make gadgets work.
0
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
Use the bottom setting of UAC to disable it. However this is not a good idea and not recommended.
0
 
jerseysamCommented:
Yes there is registry key you can check:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Change EnableULA key to 0

You can also then check registry key for Gadgets.

Summary here:

http://www.blogsdna.com/2189/fix-windows-7-sidebar-gadget-not-working-when-uac-is-disabled.htm
0
 
rindiConnect With a Mentor Commented:
DON'T turn UAC off.

Try another user account. But anyway, although gadgets should still be available within Windows 7 (Which from your Question title is what you are using), they have been identified as being a possible security hole (the reason why they aren't available on Windows 8.x anymore). So it might be a good idea to not use them anyway.

If this is a company PC, it is also possible that a policy has been put into place to disable them.
0
 
Joseph DalyConnect With a Mentor Commented:
I would take a look to see if this has been applied to your machine.

http://support.microsoft.com/kb/2719662
0
 
RayRiderAuthor Commented:
All your comments has lead me to conclude that this was disabled in some update. I took a look at the update history and could not find the specific one (too many). However, a Google search lead me to a MS Technet article that allow me to "fix it", either turn them on, or turn them off.

I like my gadgets. I decided to take the risk and turned them on.
0
 
JohnBusiness Consultant (Owner)Commented:
@RayRider - Thanks for the update and I was happy to assist.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.