P2V RH Linux to VMWARE ESX 5.1

Posted on 2014-04-04
Medium Priority
Last Modified: 2014-08-03
When trying to P2V the RH Linux machine to ESX 5.1, I receive the error that I it can't query the Linux source machine.  I searched the NET and also asked support - without an answer so far.  Port 22 is definitely open, /tmp directory is writeable and there are no echo commands in the .bashrc file.  I also uninstalled 5.1 converter and tried 5.01 converter -- same result.  Does anyone have other ideas?
Question by:apsutechteam
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Expert Comment

ID: 39978657
Are you connecting using IP address?  That often resolves a lot of problems for me in these kinds of transitions.

If you can't resolve hostnames, you might want to check your DNS settings.  You can also try pinging back and forth between the systems using IP and hostname.
LVL 123
ID: 39978819
see my EE Articles, try VMware vCenter Converter Standalone 5.5, have you checked your version of Linux is supported for conversion?

HOW TO: FAQ VMware P2V Troubleshooting

HOW TO:  P2V, V2V for FREE - VMware vCenter Converter Standalone 5.5
LVL 21

Expert Comment

ID: 39978913
Are you able to connect to port 22 with root, on the windows box that have converter installed? Take a look of the converter log (C:\ProgramData\VMware\VMware vCenter Converter Standalone\logs) , what is the error that logged?
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  


Author Comment

ID: 39979303
Yes -- I can SSH from the converter machine as Root on port 22. Thanks for your reply - the error from the log is below.

2014-04-04T10:32:49.083-05:00 [10384 error 'Default'] Sysinfo Query failed with error [Converter Agent SysinfoQuery] execution of vmware-sysinfo failed; return code: 139; result: ./vmware-sysinfo-lin32.sh: line 21: 16560 Segmentation fault      LD_LIBRARY_PATH="$abslibdir" "$libdir"/$binary "$@"
LVL 21

Expert Comment

ID: 39979464
What version of RHEL (uname -a) and converter? Can you post the follow?

From converter-
ipconfig all

Open in new window

From RHEL -
cat /etc/sysconfig/network-scripts/ifcfg-eth*

Open in new window


Author Comment

ID: 39992478
The info you requested is below.  I have tried both IP address and name without success.
For converter version, I've tried 5.0.1 and 5.1.  RH version is  uname --version -
uname (GNU coreutils) 5.97 .  I haven't tried 5.5 converter -- but I'm only on version 5.1 for everything else.


Windows IP Configuration

   Host Name . . . . . . . . . . . . : apbrvcenter
   Primary Dns Suffix  . . . . . . . : domain.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : domain.com

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter
   Physical Address. . . . . . . . . : 00-0C-29-FB-C2-E8
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

# Broadcom Corporation NetXtreme II BCM5708 Gigabit Ethernet
LVL 21

Expert Comment

ID: 39993154
Your ip configurations are straight forward and it shouldn't be the issue.

I suggest trying with converter 5.5. I am using converter 5.5 for p2v on the production environment with my 5.1 ESX hosts and haven't see any issue. (As long as you choose the correct vmware hardware)

5.5 converter contains many bug fixes that it may have solve your issue.

Author Comment

ID: 39994682
Have tried Version 5.5 -- unfortunately, the result is the same error - unable to query source.

LVL 21

Expert Comment

ID: 40002142
Are you able to P2V RHEL server on the same subnet before?

Sorry ,looks like with this type of error (Segmentation fault), you might have to engage vmware to get this resolved. It indicates that there is an exception and the P2V could not understand or handle.

Accepted Solution

apsutechteam earned 0 total points
ID: 40226894
To let everyone know, my problem I think is a Xen kernel -- I've found article that this kernel isn't supported with VMware.  I did talk to VMware and this was their thought.  I have no alternate kernels configured - so I can't prove a new kernel would fix it -- but I think it would.

Author Closing Comment

ID: 40237094
A solution was proposed for my problem that was helpful.  VMware support suggest Xen kernel was the problem.

Featured Post

10 Questions to Ask when Buying Backup Software

Choosing the right backup solution for your organization can be a daunting task. To make the selection process easier, ask solution providers these 10 key questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question