Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2010SP  IPhone/Cannot Send Mail

Posted on 2014-04-04
21
Medium Priority
?
5,917 Views
Last Modified: 2016-10-11
Cannot Send Mail. The message was rejected by the server because it is too large. I have few Iphone users that keep getting this error.  I checked the E2K10 DB and user mailbox for any quota limitation and all is good. Please help!
0
Comment
Question by:tomfontanilla
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 7
  • 3
  • +1
21 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39979277
Is it your server doing the rejection or a 3rd party server?

Have you modified the default send/receive limits of 10mb globally?

Alan
0
 

Author Comment

by:tomfontanilla
ID: 39979280
I tried that, no luck!

C:\Windows\System32\inetsrv\appcmd.exe set config "Default Web Site" -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost
0
 
LVL 11

Expert Comment

by:Murfur
ID: 39979311
What is the server quota limitation and how big is the attachment?
What app are the iPhone users using to send the message (I could assume Mail but safer to ask!)
What is the exact error message?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 

Author Comment

by:tomfontanilla
ID: 39979388
"Cannot Send Mail. The message was rejected by the server because it is too large."
Above is the exact error.
iPhone users are using Active Sync.
The email is a thread of conversation, replying with attachment  and without. With attachment, it is less done 3mbs.
0
 

Author Comment

by:tomfontanilla
ID: 39979389
On hubs 40mb on the mailboxes DB. No limits.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39979774
Can you please post a copy of the error message.

Thanks

Alan
0
 
LVL 11

Expert Comment

by:Murfur
ID: 39980101
I wear several email hats so have several accounts on my iPhone and I have encountered a similar problem, albeit intermittently and now I think about it, when I've been "roaming". So it has been interesting to dig into this as a couple of the email accounts are Exchange & now I know what to pass on to my IT bods. Hurrah!

Anyway, the digging reveals a possible cause and solution:

Apparently if you use certificate based authentication and you attempt send an attachment you can get stuck in a negative reality inversion! (see The Young Ones, S02E05 "Sick", 1984)

But to paraphrase a few sources (see below) as a summary, the server receives enough data to process the headers but does not receive the entire request. IIS attempts to answer the request with client certificates but fails to renegotiate the connection because the client is still waiting to send the remaining data from the initial POST.

There is a setting in IIS called uploadReadAheadSize that has a default of 48k and if increased could resolve this. Using 10Mb as below effectively sets your limit at 10Mb:

C:\Windows\System32\inetsrv\appcmd.exe set config -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost

C:\Windows\System32\inetsrv\appcmd.exe set config "Default Web Site" -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost

Open in new window

After this restart the IISAdmin service to load the changed setting.

Give it a whirl & all being well, head home for tea and medals!

Let us know how you get on, would be good to know if this works for you & ditto if anything develops with my IT people.

Sources:
https://discussions.apple.com/thread/5337946

http://technet.microsoft.com/en-us/library/cc737382%28WS.10%29.aspx

http://social.technet.microsoft.com/Forums/exchange/en-US/52f58b47-b95e-4f44-bb4e-6bd8b1b4eb94/iphone-sending-attachment-problems
0
 

Author Comment

by:tomfontanilla
ID: 39980306
Alan,
This the exact error.
"Cannot Send Mail. The message was rejected by the server because it is too large."
0
 

Author Comment

by:tomfontanilla
ID: 39980308
Murfur,

See my previous comment. I did exactly what you said, prior to posting here in expert exchange. The bottom that didnt help.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39980316
Is it your server rejecting the message for being too large or the receiving server?

Alan
0
 
LVL 11

Expert Comment

by:Murfur
ID: 39980567
Probably a silly question Tom, but did you apply BOTH update commands?
0
 

Author Comment

by:tomfontanilla
ID: 39980648
Yes.
0
 

Author Comment

by:tomfontanilla
ID: 39982925
Alan,
The answer to your question is yes.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39982927
Could you please re-read my question and then answer again.

Many thanks

Alan
0
 

Author Comment

by:tomfontanilla
ID: 39982993
Our is server rejecting the message for being too large. Below is the exact error message.

"Cannot Send Mail. The message was rejected by the server because it is too large."
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 2000 total points
ID: 39983014
Please check your web.config file (as per the link below) and make sure the size limit is set to a more suitable size.

http://msexchange.me/2013/07/26/exchange-active-sync-message-size-limit/

Alan
0
 

Author Comment

by:tomfontanilla
ID: 39986054
Alan,
That is similar fixed to my earlier post. But i will give a shot anyway.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39986066
It looks very different to me and optimistically should solve the problem, but only time will tell.

Alan
0
 

Author Closing Comment

by:tomfontanilla
ID: 39989062
Alan,
I believe you got this on the nose. I haven't heard any issues, and all my testing were successful. Great find. Thank you.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 39989144
Excellent news - long may it stay that way.

Thanks for the points.

Alan
0
 

Expert Comment

by:rafael M
ID: 41838916
Did you have to reboot the exchange server after this modification? please advise,

Thank you,
Rafael
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question