Solved

Custom Windows 7 Machine not able to install specific software

Posted on 2014-04-04
9
844 Views
Last Modified: 2014-06-17
Hello There:

I seem to have run into a very peculiar issue.  I built a Windows 7 machine, and it is not allowing me to install specific software on the machine.

SPECS:

Operating System:       Windows 7 Enterprise 64-bit SP1
CPU:                               Intel Core i7 4770 @ 3.40GHz
RAM:                              32Gb DDR3 @ 800MHz (11-11-11-28)
Motherboard:               ASUSTeK MAXIMUS VI EXTREME
Graphics:                      2x PNY NVIDIA GeForce GTX 770's
Storage:                        4Tb Seagate HDD
                                     750Gb Samsung SSD 840 EVO

The first encounter of a piece of software that we were having trouble with happened to be the NetAgent for Kaspersky. At first we thought maybe it was just a Kaspersky thing, and checked their forums, but after reading up on possible bits of software to install, we tried installing other bits of software, but the installers just wont work. After reading on the forums of ASUS (I tried installing the ASUS suite that checks if all drivers are up to date, and that was not installing either) a lot of people are saying it's the UEFI compatibility with Windows 7. It appears that any software that tries to access the lower level will not work.

Others are stating that they have ran into this same issue, and the "only" fix is to apply Windows 8/8.1.

I know this summary is rather vague, but I was hoping I could throw this up here for the time being, and if you have any questions, or would like more information, please just let me know. I can gather any additional bits of info that you want, I just really don't know where to start. I have tried the very basic troubleshooting steps (system restore, malware scans, windows updates, etc.) to no avail.

Thank you ahead of time for your patience and understanding. Again, any and all recommendations/suggestions/advice is greatly appreciated.

Thanks,

Crossroads
0
Comment
Question by:Crossroads305
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 51

Expert Comment

by:Netman66
ID: 39979478
Try fixing the Windows installer.

Run from elevated CMD prompt.

Msiexec /unregister

Then

Msiexec /regserver

Reboot and try again.
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 39979506
Netman, thanks for the suggestion. I was able to successfully perform those steps, but upon rebooting I am still not able to do what I need to do. Is there anything else I can try?
0
 
LVL 51

Expert Comment

by:Netman66
ID: 39979514
Can you post a typical event log for MSI Installer when this fails?
0
Resolve Critical IT Incidents Fast

If your data, services or processes become compromised, your organization can suffer damage in just minutes and how fast you communicate during a major IT incident is everything. Learn how to immediately identify incidents & best practices to resolve them quickly and effectively.

 
LVL 1

Author Comment

by:Crossroads305
ID: 39979519
Hoping this helps. If there is any other way you want this to be displayed just let me know.

Thanks,

Mike Widel
msiinstaller1.JPG
msiinstaller2.JPG
0
 
LVL 51

Expert Comment

by:Netman66
ID: 39979523
Did you read through this?
http://support.microsoft.com/kb/834484
0
 
LVL 54

Expert Comment

by:McKnife
ID: 39980145
Please give examples for softwares that work.
And for those that don't please quote the error messages. (I know, we have the event log for one, yes, but we need the error message also and not only for Kaspersky).
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 39983790
McKnife, I can provide more information tonight when I am able to access the machine.

As for software that works, I was able to install CCleaner, MalwareBytes, SuperAntiSpyware, and a few other monitoring tools just fine without any issues. I tried to install the ASUS Driver suite thing (tool to see if all drivers are up to date, etc.) and that doesn't give me an error, but will not install whatsoever.

I will quote any and all error messages that I receive when I am able to work on the machine.

Thanks
0
 
LVL 1

Author Comment

by:Crossroads305
ID: 39984830
Okay,

So upon trying to install Kaspersky again, the error that is given is "Fatal error during installation. (Unexpected error registering Network Agent.) I have googled this error to no end, and every forum I have come across does not have the solution that works for this machine.

Upon trying to install the Asus Suite driver thing, it just runs the setup and hangs on the installer. It will not progress, no matter how many times I try it, but it will not display any error. I inserted the disk that came with the MOBO, but all of the utilities on there were outdated, and the drivers were also outdated.
0
 
LVL 54

Accepted Solution

by:
McKnife earned 500 total points
ID: 39985119
I don't know what to make of it. Your windows installer could be broken.
Try sfc /scannow from an elevated command line. If that does not help, do an inplace upgrade (aka repair installation) which should help. To do this, insert a windows 7 DVD that has sp1 already on it and select install, then upgrade.
Might be a good idea to create a full image backup, first.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
No matter the version of Windows you are using, you may have some problems with Windows Search running too slow or possibly not running at all. Before jumping into how you can solve this issue, just know there are many other viable alternative deskt…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question