Solved

Can Ping but Not Browse

Posted on 2014-04-04
13
2,388 Views
Last Modified: 2014-04-05
I can ping but I cannot browse.

Ping times seem to be ok, they are in the 65 ms range.  

I am pinging google.com.

Other computers on the network and smart TV work ok.

Before I started attempting to troubleshoot this issue it was an intermittent thing.

So today I purchased and installed a new D-Link wireless usb adapter thinking that my old one was just dying a slow death or something.

It worked initially.  I was so happy.  Even got some work done using remote desktop and ie explorer 11 on a windows 7 machine.

After that I fired up my VMWare to get some more work done and it went back to being intermittent and slow and flaky.

I tried doing an ipconfig renew and other tests which all seemed ok.  I uninstalled a bunch of windows updates thinking that they might have been the cause but it only made it worse.

I can't pull up any websites at all.

I uninstalled chrome and found out that you can't uninstall IE.

I restarted the machine and I am currently re-running windows update.

If anyone has a method or a troubleshooting series of steps to help me track down and fix this issue, I would be forever grateful as it is interfering with my work production as it is driving me crazy.

Thanks in advance,
~AJ
0
Comment
Question by:ajthomas12
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
  • +2
13 Comments
 
LVL 95

Assisted Solution

by:John Hurst
John Hurst earned 100 total points
ID: 39979400
Ping but cannot browse is normally two things:  DNS and/or Firewall.

Check the DNS in your wireless router and wireless connection. If you have a router, ADD 4.2.2.2 to the DNS table in the router WAN connection.

If you do not use a router, but one computer direct connection, ADD 4.2.2.2 into the DNS section of the TCP/IP settings.

In your computer, check your HOSTS file. C:\windows\system32\drivers\etc and make sure all the entries in it are comments.

Also try resetting TCP/IP (do this before adding the DNS entry)

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Restart the computer

Remake wireless profiles as needed,

You might also try flushing DNS to check that (again, before adding the DNS entry)

ipconfig /flushdns followed by net stop dnscache followed by net start dnscache

Try these things and please let us know.
0
 
LVL 83

Accepted Solution

by:
Dave Baldwin earned 350 total points
ID: 39979444
Wireless connections do odd things when they are marginal.  I would first check the connection with a wired network connection before I did any of those other things.  That's always my first test when I have problems with network connections over wireless.
0
 
LVL 26

Assisted Solution

by:Fred Marshall
Fred Marshall earned 50 total points
ID: 39979484
DNS should be OK if you're pinging a name and getting it as in "google.com" or "www.google.com".
0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 

Expert Comment

by:James Peifer
ID: 39979539
I noticed that you mentioned having this problem after bringing back up your VMware virtual machines.  Have you thought about checking the connection settings in the virtual network adapters created when you install a local VMware program (desktop/player)?  It is possible that there is something in your hosts file or dns that is trying to use one of the virtual adapters for your internet traffic which can cause a slow if not stopped traffic speed.  I am not sure but it seems as though you did alot of cleaning and changes to make things appear back to normal and then it all went south again with the start of the VMware program.  I'd check the settings on your virtual adapters as well as any entries that may have been entered into your NAT router or firewall.  Another possibility is that the VMware virtual network adapters on your computer have become the entry point or forwarded port from your firewall which will cause the slow down or even intermittent connections when using your local browser for internet.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39979545
I use virtual machines a lot and they do not cause this issue - but there is a always a first time.  I did suggest checking HOSTS earlier.
0
 

Author Comment

by:ajthomas12
ID: 39979571
Thanks for the quick responses all,

My hosts file checks out.  It's all comments.

I turned off my firewall and restarted.  The cable modem's firewall is set to low.

No change.

I did the reset, the flush, and the stop and start ... and restarted.

Could not access a web page.  Tried to ping google.com and got, Ping request could not find host google.com.

I waited a few minutes and tried again, this time I got back the four replies and they were right around 177 ms.  Which seems awful slow to me.

Which reminds me, slowness is a symptom.  Sometimes the little rotating circle on IE and chrome spins fast and sometimes it is very slow.

I was able to login to my cable modem and it looks like Dynamic DNS is disabled.
However, I'm not sure if this is where I should try putting in the 4.2.2.2 address anyway. ??

It is not practical for me to connect a cat cable to the back of my cable modem and my signal strength on the wireless connection says it is excellent, however, I think I may be able to reposition the wireless adapter to make it better.  I'm going to try that next.

I'm not sure what, 'remake wireless profiles' means.

Please let me know if you have any more suggestions / things I can try.

Thanks,
~AJ
0
 
LVL 83

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 350 total points
ID: 39979627
I had one client who's wireless signal strength was 'excellent' but he just couldn't get it to work.  It should have been 'excellent', he had two neighbors on the same channel.  As soon as we changed the channel, everything started working just fine.
0
 

Author Comment

by:ajthomas12
ID: 39979666
Dave,  

That's very interesting.  It somehow makes sense to me, that these could be interfering.  I can see an unsecured xfinity wifi that's on the same channel as me and there are two others as well.  

How does one go about changing the channel?

Thanks,
~AJ
0
 

Author Comment

by:ajthomas12
ID: 39979670
So I decided to try and back track a bit.

Everything worked for a while, before I started my VM, and after I installed the new D link adapter.

so I pulled out the adapter and uninstalled the D link software.

Then put the disk in and went through the install steps again... it's working.

My google ping times dropped to about 40 ms, which seems more inline with where they were before things started going haywire.

I was also able to open 9 tabs of websites and all worked.  Speedtest.net said I had download speeds in the 27 Mbps / 6 Mbps range.  Great!

Now the question is, will it last when my neighbors get on their wifi in the morning and / or when I attempt to fire up my work VM again.

I'll fire up my VM when I get a chance tomorrow, if everything is still working that is, and see what happens.

I'll keep you posted.

~AJ
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 39979694
Some wireless routers claim to 'automatically' select the channel for you but on the Wireless configuration page should be options to choose 'auto' or a specific channel.  Also, if your router and wireless adapter will operate at 5GHZ on Wireless-N, you will likely see less interference.  But maybe not as much range.  That depends on whatever metal objects are inline between the computer and the router.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 39979992
You might wish to try a different wireless card (USB device) to see if that makes a difference.

Also ask your ISP to reset the cable modem. This means setting up wireless on the modem again.
0
 

Author Comment

by:ajthomas12
ID: 39980286
I opened the work vm today and nothing blew up.  I can connect to web pages both on the VM and on the base machine.  Ping times are still good.

so...

I think the solution was relocating the USB adapter to improve the signal, even though it said my signal strength was excellent this whole time.  

When I backtracked and uninstalled and re-installed the D link usb adapter, I used an extension dock that came with it which moved the adapter 2 feet off the floor and allowed me to point it in the general direction of the cable modem.

So I will award the majority of the points to Dave who stated, "Wireless connections do odd things when they are marginal.", because what was going on was definitely odd.

Thanks to everyone,
~AJ
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 39980299
You're welcome, glad to help.
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
checking for updates 11 85
Does Mavic Pro & Phantom 4 drones deal well with wireless interference? 4 67
Cisco Licensing for Wi Fi 4 77
Windows 10 ISO build version 3 93
For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question