?
Solved

Exchange 2010 Consistency Check Error

Posted on 2014-04-05
9
Medium Priority
?
491 Views
Last Modified: 2014-04-07
Hello,

OS 2008R2 Exchange 2010

I've had a problem with a Hard disk and backups have been failing for two weeks, eventually had to replace HDD and restore from a backup I managed to take manually.

Now when I run Windows Server Backup it fails the Exchange Consistency check and says...

"The application 'Exchange' will not be available in the backup created..."

I have run ESEUTIL /K E00 and there appears to be an error with at least two of the log files, I've attached the output in LOG2.TXT

Can someone have a look at it please and let me know a course of action, emails are currently flowing and store mounts OK and is in a clean shutdown state.

Thanks for your time.

Dave
log2.txt
0
Comment
Question by:Declaro
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 8

Expert Comment

by:Esteban Blanco
ID: 39980761
Hey Dave,

This is a tricky one.  Have you tried deleting the log (create a copy just in case of course) and see if that works?

Normally this happens as you know when a log file is corrupted.  Sometimes deleting the corrupted log file can fix this problem.

To properly delete the log file AFTER creating its backup, you have to dismount the database.

Let me know if that helps.

Esteban
0
 
LVL 1

Author Comment

by:Declaro
ID: 39981101
Hi, Thanks for the reply.

I tried moving the two logs to a new location and the database still mounts but the backup still fails the consistency check.

In the attached txt file from previous post it says that the E00.log file is corrupt too (I Think) I tried to move that log as well and the database wouldn't mount.

Any more ideas?

Thanks for your time

Dave
0
 
LVL 10

Accepted Solution

by:
santhoshu earned 1000 total points
ID: 39981113
Can you try Eseutil with /d or /p switch and try to repair the database.

For more information check
http://www.petri.co.il/forums/showthread.php?t=23880
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:Declaro
ID: 39981122
My Database is on D: and Logs and exchange install is on C:

would my command be...

C:\exchange...\bin>eseutil /d D:\Mailbox Database\Mailbox Database 0239682372.edb /t C:\TEMP\Mailbox Database 0239682372.edb /p

I'm really unsure about ESEUTIL

Thanks

Dave
0
 
LVL 8

Assisted Solution

by:Esteban Blanco
Esteban Blanco earned 1000 total points
ID: 39981424
Dave,

Here is an article from Microsoft on how to use ESEUTIL

http://support.microsoft.com/kb/2616952
0
 
LVL 1

Author Comment

by:Declaro
ID: 39981857
Hi,

I ran eseutil /k "Mailbox Database xxxxxxx.edb" and it came back with five checksum errors.

I've read a lot of horror stories about eseutil repairs and have created a new database and I'm in the process of moving over the mailboxes to the new database. I'm going to see how that pans out before I consider a repair, plus if it works I'll have a brand new uncorrupted store for the mailboxes.

Thanks for the help so far, I'll post back with the results.

Cheers

Dave
0
 
LVL 10

Expert Comment

by:santhoshu
ID: 39982127
That is a great idea.  You can create a new DB and move your mailboxes there.
0
 
LVL 8

Expert Comment

by:Esteban Blanco
ID: 39984165
Sounds good to me as well.
0
 
LVL 1

Author Comment

by:Declaro
ID: 39984398
Fixed it in the end...

To get rid of the corrupted log files I killed all the exchange services, I renamed the mailbox database and logs folder to "OLD" and created another one with the original name, then COPIED only the mailbox.edb file into the new folder,  marked the store to be overwritten by a restore, then restarted all the services except the IS which is started last. If the store doesn't mount automatically you can start it manually.

Then I created a new mailbox database in EMC and did a local move request for all the mailboxes including the arbitration mailboxes. then deleted the old database from EMC

After this the backup has run successfully and has passed the exchange consistency check

Thanks for all your input it was appreciated, I've awarded the points to you two because it gave me a lot of info on ESEUTIL

Thanks

Dave
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
Read this checklist to learn more about the 15 things you should never include in an email signature.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question