Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 593
  • Last Modified:

New Exchange Server 2010 installation - no external emails coming in, or going out

Fresh install of Exchange 2010 on Server 2008 Standard.

Mailbox database restored from backup from previous installation; mailboxes reconnected.

Internal mail is fine.

Mail destined for outside is sitting in queues delayed.   No mail is coming in from outside of domain (have sent test emails from outside domain - receive error 530.5.7.1)

Mail should be relayed through ISP smart relay - have confirmed credentials with ISP

Public address folder Database is not mounting properly.

In the process of running Baseline Microsoft Exchange Best Practices Analyzer Health Baseline scan (about an hour to go).

Any suggestions on what I'm missing....?   I've got until Monday morning to make this work!
0
Lisaa_G
Asked:
Lisaa_G
  • 6
  • 2
  • 2
3 Solutions
 
Jason_PerrymanCommented:
Regarding the 530.5.7.1 you need to create an External Domain Receive Connector.  Open Exchange Management Console, expand Server Configuration, select Hub Transport.  Create a new Receive Connector call "Internet" or whatever you'd like and in the Permissions Tab make sure only Anonymous Users checkbox is selected.

In regards to outgoing mail is your Send connector properly configured?  Open EMC, expand Organization Configuration, select Hub Transport and click the Send Connectors tab.  I usually configure 1 additional send connector to relay through my ISP for problematic domains.  In that connector I select the Network tab, click the radio button beside "Route mail through the following smart hosts and put in my ISP mail server hostname.
0
 
Lisaa_GAuthor Commented:
What do you specify as address / port on this connector ?  (Internet receive connector) - external IP address?
0
 
Jason_PerrymanCommented:
On the Receive connector Network tab, top window should have (All available IPv4 addresses) and port 25.  Bottom box should be 0.0.0.0-255.255.255.255  I believe these are the defaults.  Also (not trying to confuse the issue) if you have any firewalls in place make sure that you have port 25 open to the IP address of the server.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Lisaa_GAuthor Commented:
perfect!  just tested and received email from an external domain.  Now just have to figure out why my SMTP connector for Smart relay through my ISP doesn't seem to be working!

Thank you!  Half my problem solved in way less time than I spent poking around and accomplishing nothing!
0
 
Lisaa_GAuthor Commented:
SMTP Connector for Smart relay is configured as follows:-

General  - Nothing under FQDN to provide in response to HELO or EHLO
Address Space:  Type SMTP / Address *  / Cost 1
Network  - selected radial button for route mail through the following smart host
                FQDN  relay.myisp.ca
                Basic Authentication
0
 
Simon Butler (Sembee)ConsultantCommented:
There was no need to create a new receive connector. All you needed to do was enable anonymous to the authentication section of the Default Receive Connector and you would have had inbound email flow.

You should have a value in the FQDN of the Send Connector - which should match what your server is known as externally (host.example.com).

Are you able to telnet to port 25 of your smart host server from the server to confirm connectivity?

Simon.
0
 
Lisaa_GAuthor Commented:
Hi Simon,

Added FQDN "mail.ourdomain.com"  - messages in queue failing with 451.4.4.0  Primary target IP address responded with "535 Incorrect Authentication data"


This seems to me the connector is configured correctly but my ISP did not in fact correctly confirm user / password credentials with me....  am I reading this correctly?

Remote Connectivity Analyzer test for Outbound SMTP email passes with a warming (SPF record not found).
0
 
Simon Butler (Sembee)ConsultantCommented:
The error means what it says - authentication error.
It might be that you don't have to authenticate, not all ISPs require that.
I would also check the server you are using is correct and isn't a Gmail server (a lot of ISPs outsource their email service). If it is, then you will have to use another service.

Simon.
0
 
Lisaa_GAuthor Commented:
Thanks!  On hold with our ISP's help desk now....
0
 
Lisaa_GAuthor Commented:
Thank you gentlemen - I do believe if our ISP had a decent help desk open on the weekends we would be out of the woods now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now