[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1064
  • Last Modified:

Add bitmap fonts for using with Fedora and xterm to Xming

I believe I have Fedora 19 and I need to be able to change xterm font, color, and size on the Putty command line like this:

bash-4.2$ xterm -geometry 132x80 -fn lucidasanstypewriter-8 -rv &
[2] 9516
-bash-4.2$ xterm: cannot load font 'lucidasanstypewriter-8'
xterm: cannot load font 'lucidasanstypewriter-8'



But, see it can not find the font "lucidasastypewirter", while xterm pop up with some
default font.  I looked online seemed to know what should be done, from here

http://www.xfree86.org/current/fonts2.html  for example

, but where to get the bitmap font files, such as courier12.pdf?  When I enter xlsfonts
I get:

-bash-4.2$ xlsfonts
-misc-fixed-medium-r-semicondensed--0-0-75-75-c-0-iso8859-1
-misc-fixed-medium-r-semicondensed--13-100-100-100-c-60-iso8859-1
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
6x13
cursor
fixed

And choosing one of above seemed no effect in the xterm rendered.  I don't really have to have a particular font, however I need have whole bunch of selection like I used to be able to do with other version of Linux package.  Am I missing anything?  Please offer suggestions;  Giving full commands solutions is high appreciated. Thanks in advance.

Ze
0
zzhang2006
Asked:
zzhang2006
  • 4
  • 3
2 Solutions
 
xtermCommented:
Please try this command, and let me know if the output on your system looks different to mine:

[xterm@foo ~]$ [b]fc-list | grep -i lucida[/b]
LucidaTypewriter:style=Sans Bold
LucidaTypewriter:style=Sans

Open in new window


On my Fedora system, this font is part of the Sun JDK in /usr/java/jdk1.x.x_xx/jre/lib/fonts/ directory.
0
 
xtermCommented:
Oh, once you have fc-list showing that you have that font ready for use, launch it with this command:

xterm -geometry 132x80 -fa "LucidaTypewriter" -rv
0
 
zzhang2006Author Commented:
Sage, this works! I just used the above, without really understand how the font system on Fedora is structured. Well, this is all I need for now.  I also notice something, the  foreground (-fg) and background (-bg) color options actually reversed,
For example



-bash-4.2$ xterm -geometry 132x80 -fa "LucidaTypewriter" -rv -bg green -fg black &

With the above command you will see green text on a black background, is this an error on Fefora?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
zzhang2006Author Commented:
But the  fc-list | grep -i Lucida  yield nothing, although I did seem lots of fonts print out when "fc-list" was entered alone.

And what is more, I found that the "-fa" option has no effect what's ever, this

 xterm -geometry 132x80 -fa "AnyJunk" -rv -bg green -fg black &

will pop up the same xterm with a default font, which has minimum quality.

Thanks
0
 
xtermCommented:
Yes, if it doesn't recognize the font supplied, it will launch the default one.  And that foreground/background reversal stuff I don't think is limited to Fedora - I've seen it act weird on multiple distributions and indeed using your exact command above on my Ubuntu box, I get the green text and black background.
0
 
zzhang2006Author Commented:
Thanks
0
 
xtermCommented:
sure!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now