Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Suddenly some email domain stuck in the queue

Posted on 2014-04-07
10
Medium Priority
?
640 Views
Last Modified: 2014-04-23
I recently installed a server and added to DAG  and shifted the database for testing.
But after that some email domains not flowing as before. it is stuck in the queue.

Even I tried switching back the database to the old server

What could be wrong?. your help appreciated.

I am using exchange2010
0
Comment
Question by:MAS
  • 6
  • 4
10 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39985213
Not really enough information to go on.
If the messages are in the queues then there should be a message in the queue to say why they are not being delivered.

Can the servers see each other?
Do you have the hub transport role on the server or on another machine?

Simon.
0
 
LVL 28

Author Comment

by:MAS
ID: 39985253
All the servers have hub transport installed.
yes they can ping each other. I can open queue viewer of server1 from server2
screenshot1.png
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39985272
Being able to open the queue just means that the servers are able to communicate using regular Windows protocols. What I mean was that the servers could communicate using SMTP for example. Check that your receive connectors have the Exchange server security permission and don't have a restriction on them for what Ip addresses can communicate.

Simon.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 28

Author Comment

by:MAS
ID: 39990828
Receive connectors are all ok and exchange security permission are there.

I have one extra rcv connector which is relaying our sister company emails.
But that is there since 3 years.

Your help is highly appreciated.
0
 
LVL 28

Author Comment

by:MAS
ID: 40006124
There was some issue with domain controller.
I restarted domain controller and exchange server.
Now 99% is working fine.
But I have an email address still stuck in queue.
If that is cleared its working 100%

Any help /guidance would be highly appreciated to troubleshoot this particular email address flow
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 2000 total points
ID: 40006804
You need to troubleshoot that specific domain, as it may not be a problem at your end. Check if you can resolve the MX records correctly, then connect to them on port 25.

Simon.
0
 
LVL 28

Author Comment

by:MAS
ID: 40008267
If I try from Gmail it works but from my exchange this is the error. See attachment.
This error only for this domain. Rest all working fine

I tried to get the mx from exchange server. I am getting the mx records.
I tried to telnet. I can only see the blank screen not giving the response as other other company mail servers do

Your quick response is highly appreciated as users started complaining now
exchangeerror.png
0
 
LVL 28

Author Comment

by:MAS
ID: 40008274
I tried SMTP test of that domain from MXtoolbox. Below is the result. I changed the original IP address with a fake IP in the result.
Do you think its our problem as Gmail works fine with this domain?
Do you think we can do something to work as Gmail works?


Unable to connect after 15 seconds.
 Test Result  
 SMTP Connect Failed To Connect  More Info  
Session Transcript:
Connecting to 222.222.222.140
4/18/2014 1:15:05 AM Connection attempt #1 - Unable to connect after 15 seconds. [15.04 sec]
MXTB-PWS3v2 15038ms
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 40008468
That would indicate the error is with the remote side, not you. If MX Toolbox isn't getting a response either then they have a problem.

Either that or they are blocking the traffic for some reason, and are also blocking MX toolbox. Could be a suspect spam filtering technique which isn't working correctly.

Simon.
0
 
LVL 28

Author Closing Comment

by:MAS
ID: 40019336
Thanks Simon
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
How to effectively resolve the number one email related issue received by helpdesks.
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Suggested Courses

824 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question