Changed Domain Admin account password now Errors going to companyweb on SBS 2008

I changed my password and I am a domain / Enterprise admin. Now no one can access the Company web page. It displays a error page with the below listed info :

Module          IIS Web Core
Notification    Unknown
Handler         Not yet determined
Error Code      0x8007052e
Config Error    Can not log on locally to C:\Program Files\Windows Small Business Server\Bin\WebApp\InternalWebSite as user kjsiet with virtual directory password  
Config File     Unavailable (Config Isolation)
Requested URL   http://companyweb:80/ 
Physical Path  
Logon Method    Not yet determined
Logon User      Not yet determined

Config Source    <application path="/" applicationPool="SBS Sharepoint AppPool">
                    <virtualDirectory path="/" physicalPath="C:\Program Files\Windows Small Business Server\Bin\WebApp\InternalWebSite" userName="kjsiet" password="[enc:AesProvider:f8JfBpR93Y96eev36geUQZy3Le3Nv3zhj1xOatmoBsnEfW4ieBBHEIvbboyx9nOP:enc]" />
                    <virtualDirectory path="/_vti_bin" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\isapi" />


All I can find is something with the app pool. But the app pool is running a an network service. I do not see the user kjsiet (which is me) being used by a server or pool anywhere.

Can anyone please help me as to where and how I can change the stored password that is giving this error.

Thanks
goodgolferAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
goodgolferConnect With a Mentor Author Commented:
Resolved on my own by the below:

IIS7
Sites
SBS Sharepoint AppPool
 Right Click
  Manage website
    Advanced Settings
      Physical Path Credentials  ( click on ...)  
       Specific User (Click on set button)

          Type in user name and current password
0
 
arnoldCommented:
Your app is likely used your credentials.
You should create a service account with appropriate rights and this is the account you would use.

Check the app pool
Check the IIS site configuration.

Is this a sharepoint site?
0
 
goodgolferAuthor Commented:
I think share point is running as part of SBS. Everything I have seen is pointing to APP Pool . But Where do I change it ? I see the default app pool running as network service. I see nothing listed as running with my account ?

When you say Check the IIS Site Configuration what are you wanting me to check and where ?  There are many items and many sites.  Please do not be so general as that does not help anyone.

Thanks
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
Lionel MMSmall Business IT ConsultantCommented:
A quick fix for right now is to put your password back to what it was and see if that fixes it. It may just be coincidence that all this happened when you changed your password. if you change it back you can know for sure. Do this through AD Users and Computers otherwise you may not be allowed to change it back
0
 
arnoldCommented:
Using the Intenet Information Service (administrative tool) you can change the app pool setting)

You have to look at the _vti_bin properties as this is where the issue seem to suggest it exists.
This directory is part of the FrontPage extensions.
0
 
goodgolferAuthor Commented:
And How do I change the app pool setting ?
How do I look at the _Vti_Bin Properties ?

And yes changing the password back worked but I can not keep it at that password for security reasons..
0
 
goodgolferAuthor Commented:
sO THE QUESTION IS REALLY !!  In what file is the encrypted password for the user kjsiet . And how do I change it ??

<application path="/" applicationPool="SBS Sharepoint AppPool">
                    <virtualDirectory path="/" physicalPath="C:\Program Files\Windows Small Business Server\Bin\WebApp\InternalWebSite" userName="kjsiet" password="[enc:AesProvider:f8JfBpR93Y96eev36geUQZy3Le3Nv3zhj1xOatmoBsnEfW4ieBBHEIvbboyx9nOP:enc]" />
                    <virtualDirectory path="/_vti_bin" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\isapi" />

None of the app pools have this user attached to them.
0
 
arnoldCommented:
I believe I suggested that you need to locate where you've added the credentials and update them.

Do not repeat your prior mistake and use your own credentials again.  Create a service account and grant it the requisite rights. Then use it for this setup.
0
 
goodgolferAuthor Commented:
Because After not getting any good detailed responses I spent a couple of hours and resolved on my own.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.