Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco Catalyst 4000 VLAN Config not working

Posted on 2014-04-08
4
Medium Priority
?
706 Views
Last Modified: 2014-04-17
We have a Cisco Catalyst switch with the attached config.  We have two VLANs 2 (Voice), 3 (Data).  The phone system is on FE 2/2 which is handing out DHCP for VLAN 2. Is there any reason with this config that if we plug a phone in to almost any other switch port that it would not get DHCP from the phone system on FE 2/2?  Does the Voice command only work for Cisco Phones?  We are trying to use Mitel phones on this setup.  

Current configuration : 9450 bytes
!
! Last configuration change at 13:54:40 EST Mon Oct 7 2013
! NVRAM config last updated at 13:56:53 EST Mon Oct 7 2013
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname XXXX
!
boot-start-marker
boot system flash bootflash:cat4500-entservices-mz.122-54.SG.bin
boot-end-marker
!
enable password !!!!!!!
!
!
!
no aaa new-model
clock timezone EST -4
ip subnet-zero
no ip domain-lookup
ip name-server 208.67.222.222
ip vrf mgmtVrf
!
!
!
vtp domain Agency
vtp mode transparent
!
!
network-policy profile 1
 voice vlan 2
 voice-signaling vlan 2
!
power redundancy-mode redundant
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
 name Voice
!
vlan 3
 name Network
lldp run
!
!
!
interface FastEthernet1
 ip vrf forwarding mgmtVrf
 no ip address
 speed auto
 duplex auto
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface FastEthernet2/1
 description DSL Router
 switchport access vlan 2
 speed 100
 duplex full
!
interface FastEthernet2/2
 description Asterisk Server
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet2/3
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/4
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/5
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/6
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/7
 description OPEN VPN ACCESS
 switchport access vlan 2
 switchport mode access
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/8
 description Asterisk Backup Sever
 switchport access vlan 2
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/9
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
!
interface FastEthernet2/10
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/11
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/12
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/13
 switchport mode access
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/14
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/15
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/16
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/17
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/18
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/19
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/20
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/21
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/22
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/23
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/24
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/25
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/26
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/27
 switchport access vlan 2
 switchport mode access
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/28
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/29
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/30
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/31
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/32
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/33
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/34
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/35
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/36
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/37
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/38
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/39
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/40
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/41
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/42
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/43
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/44
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/45
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/46
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/47
 network-policy 1
 spanning-tree portfast
!
interface FastEthernet2/48
 description Fiber Router
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
!
interface GigabitEthernet3/1
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/2
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/3
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/4
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/5
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/6
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/7
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/8
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/9
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/10
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/11
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/12
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/13
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/14
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/15
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/16
 switchport access vlan 2
!
interface GigabitEthernet3/17
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/18
 switchport access vlan 2
!
interface GigabitEthernet3/19
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/20
 switchport access vlan 2
!
interface GigabitEthernet3/21
 switchport access vlan 2
!
interface GigabitEthernet3/22
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/23
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/24
 description POTS Router
 switchport access vlan 2
!
interface GigabitEthernet3/25
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/26
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet3/27
 switchport access vlan 2
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/28
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/29
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/30
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/31
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/32
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/33
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/34
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/35
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/36
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/37
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/38
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/39
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/40
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/41
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/42
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/43
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/44
 network-policy 1
 spanning-tree portfast
!
interface GigabitEthernet3/45
 description Fiber Router
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet3/46
 description Connection to xxx.xxx.xxx.xxx network
 switchport access vlan 3
!
interface GigabitEthernet3/47
 description Connection to xxx.xxx.xxx.xxx network
 switchport access vlan 3
!
interface GigabitEthernet3/48
 description Connection to My Network
!
interface GigabitEthernet4/1
 description Available
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet4/2
 description Fiber to IDF 2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed nonegotiate
!
interface GigabitEthernet4/3
 description Fiber to IDF 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
interface GigabitEthernet4/6
!
interface Vlan1
 no ip address
!
interface Vlan2
 ip address 10.222.6.250 255.255.255.0
 ip helper-address 10.222.6.252
!
interface Vlan3
 no ip address
!
ip route 0.0.0.0 0.0.0.0 10.222.6.254
ip http server
!
!
!
logging trap notifications
logging facility local0
logging xxx.xxx.xxx.xxx
!
!
snmp-server community !!!!!!!!!!!!!!!!!
!
control-plane
!
!
line con 0
 stopbits 1
line vty 0 4
 password !!!!!!!
 login
!
ntp clock-period 17179538
ntp server 64.90.182.55
ntp peer 10.222.6.252
end

XXXXXXX#
0
Comment
Question by:ClearBlueTechnologies
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 57

Expert Comment

by:giltjr
ID: 39988432
Did you configure you phones to use vlan 2 tagged?

Specifying "voice VLAN 2" says that VLAN 2 is for voice, but it needs to be tagged.  So the phones need to tag  with VLAN 2.

The excption to this is if you put a phone as the ONLY device on a switch port and set the switch port as access mode VLAN 2 or trunk mode and make the native VLAN 2.
0
 
LVL 22

Expert Comment

by:eeRoot
ID: 39990187
Is this the IP of your DHCP server?  "ip helper-address 10.222.6.252"

And are you using a phone that is programmed to use VLAN 2, and it is programmed with the IP of the VoIP server?

Is there a DHCP scope option that has the phone system's IP address?
0
 
LVL 12

Accepted Solution

by:
Infamus earned 2000 total points
ID: 40005309
You need to use "switchport voice vlan 2" statement

interface FastEthernetx/x
 description xxxxxxxxxxxxx
 switchport access vlan 3
 switchport voice vlan 2
 switchport mode access
 network-policy 1
 spanning-tree portfast
0
 
LVL 1

Author Closing Comment

by:ClearBlueTechnologies
ID: 40006351
That worked Infamus...thank you for the help!
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSL is a very common protocol used these days when browsing the web.  The purpose is to provide security to communication, but how does it do it?  There are several pieces at work that have to be setup before SSL will even work and it requires both …
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question