• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3844
  • Last Modified:

Ping Windows NetBIOS names from CentOS

I am unable to resolve windows NetBIOS names from inside CentOS.  I've tried the following:

Adding "wins" entry to "hosts:" in nsswitch.conf ("files wins dns")
Changing the order of "files", "wins", and "dns" in nsswitch.conf
Restarting networking "service network restart"
Adding "search WORKGROUP" to resolv.conf (replacing WORKGROUP with my particular workgroup)
Installing samba-common
Restarting the machine

I'm kinda out of options, and I'm not sure where to go from here.  From what I've read, adding wins to nsswitch.conf should solve it, but that doesn't work for me.

I'm able to ping the computers via IP address, and I can resolve the NetBIOS names on Windows machines.  I don't think it's a firewall issues, because when I stop iptables, the issue persists.  It could maybe be an SELinux issue, but I don't really know where to start troubleshooting that.

Help me, EE, you're my only hope!
0
nick2253
Asked:
nick2253
1 Solution
 
Dave BaldwinFixer of ProblemsCommented:
As far as I know Samba is the only thing that even looks at NetBIOS on a Linux machine.  It is also the only thing that knows about 'workgroups'.
0
 
gheistCommented:
WINS is not NetBIOS
You need more than samba-common to get netbios names. At least package containing nmbd is needed.
0
 
Dave BaldwinFixer of ProblemsCommented:
I think that 'ping' does a DNS lookup when you give it a host name.  There is no reason to think that the NetBIOS names are in DNS unless you did something to put them there.  On my Ubuntu systems, I had to add all of my Windows machines that have web servers to my 'hosts' file to connect to them by name.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
serialbandCommented:
There are some instructions on how to set samba up to resolve Wins.  Maybe the following links can help.  https://www.ibm.com/developerworks/library/l-lpic3-314-2/
http://forums.opensuse.org/showthread.php/454546-nmblookup-resolves-but-cannot-ping-netbios-names-or-ping-FQDN

Those eventually link to the Samba Docs which suggests that you must also edit smb.conf to configure SAMBA to point to the WINS server
Edit these lines in smb.conf
wins support = No
wins server = xxx.xxx.xxx.xxx


Scroll down to the WINS Lookup section in https://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/integrate-ms-networks.html#id2586120

You need nmbd to run nmblookup to look up names, but that's independent from ping. http://linuxcommand.org/man_pages/nmblookup1.html
0
 
gheistCommented:
setting "wins" in nsswitch.conf implies querying nmbd (which can be configured with or without WINS server)
Name itself causes confusion, no wins server is needed to support pinging netbios names.

Why dont you enable DNS auto-registration in your DNS server and rise above archaic useless naming protocols?
0
 
SandyCommented:
Yes enable DNS auto-reg in your DNS server.

TY/SA
0
 
nick2253Author Commented:
This didn't actually resolve my issue of getting "ping" to work with NetBIOS names (though it did allow me to get names through nmblookup), but I've since changed my DNS structure in my network, so it's no longer an issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now