Solved

Cisco SF300-48 and issues with DHCP/VLAN/Voice

Posted on 2014-04-10
2
966 Views
Last Modified: 2016-02-14
Hi People



I need some assistance for an issue where IP Phones receive an IP address from the incorrect scope, they continue to receive an address on the LAN scope, when they should be getting an IP from the VOIP scope.

the switch details are as follows

Firmware is latest 1.3.7.18

Layer 3 mode is enabled

VLAN 1 for Data is on 10.132.74.13 Untagged

VLAN 100 for Voice is on 192.168.240.253 tagged

vlan routing between these is fine.

I am able to ping both vlan interfaces from the Windows DHCP Server.

DHCP relay has been configured and the IP Helper has also been setup to point to the DHCP Server on 10.132.74.74

The port (fe2) the phone is currently into is set to trunk mode as the PC's will plug into the phones and the phones into the switch.

whatever i do the phones always seems to get an IP from the LAN scope on 10.132.74.x as opposed to the VOIP scope on 192.168.240.x, from what  i have read these switches have an auto voice vlan function (also setup) that auto senses and configures the correct VLAN ID based on preset macros.

i have attached a word document that contains a series screen shots from the GUI.

Normally on a Catalyst i would have used the cmds below, however these dont accepts these commands.

interface fe0/2
 description data and voip
 switchport access vlan 1
 switchport mode access
 switchport voice vlan 100

Any pointers greatly appreciated.
SF300.doc
0
Comment
Question by:dyson8604
2 Comments
 
LVL 6

Expert Comment

by:Hassan Besher
ID: 39992658
i think it's a cdp issue:

Click Administration > Discovery - CDP > Properties.
STEP 2 Enter the parameters.
• CDP Status—Select to enable CDP on the device.


• CDP Voice VLAN Advertisement—Select to enable the device to advertise
the voice VLAN in CDP on all of the ports that are CDP enabled, and are
member of the voice VLAN. The voice VLAN is configured in the Voice VLAN
Properties page.



also this is configuration guide for the switch read Voice Vlan section, it's very helpful:

http://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/78-19308-01.pdf

Good Luck :)
0
 
LVL 3

Accepted Solution

by:
JAmenta earned 500 total points
ID: 40419988
You need to give your phones access to the DHCP scope for the voice subnet.  Currently, you have a helper address for the data subnet DHCP server, but not voice.  If you add a helper address for the voice subnets DHCP server you should see the phones receive the correct addresses.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question