Solved

tandberg rdx on ubuntu linux will not eject

Posted on 2014-04-10
11
1,244 Views
Last Modified: 2014-04-14
I installed an external tandberg rdx on an ubuntu linux server a year ago. There are three exchangeable 500Gb cartridges. I have set up cron jobs for each day of the week, backing around 40Gb a day to folders monday, tuesday, etc
The user ejects the cartridge once a week using the ubuntu desktop and loads the next in sequence.
For the last few weeks they have been unable to eject the cartridge.
I have updated to the latest version of the OS. Restarted several times, removed power from the tandberg caddy, etc.
It just will not eject. The data is all visible and the backup works.
I used an ssh session to mount and umount the device - all as it should be
also eject -v /dev/sdc1 - the response is scsi eject successful but it still does not actually eject.
There is a small hole on the drive above the cartridge. I tried a paperclip in there but without result.
Any suggestions?
0
Comment
Question by:peter_lawrie
  • 6
  • 5
11 Comments
 
LVL 62

Expert Comment

by:gheist
ID: 39993129
lsof /dev/rmt0
0
 

Author Comment

by:peter_lawrie
ID: 39998950
Thanks
I tried lsof /dev/sdc1 - there are no open files
I used udisks --unmount and --detach but still could not remove the disk cartridge
The backup did work on thursday and friday night after my previous visit
I removed power from the rdx caddy and disconnected the usb, restored power and reconnected - still will not eject
After reconnecting usb, ubuntu files listed the contents again
I noted that instead of /media/aam/RDX-500 it now shows /media/aam/RDX-5002
I don't appear to have any control over this, so had to amend the crontab

This is the only ubuntu machine I currently have to deal with. My other customers all have Centos.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39999470
you can try
mt
mtx,
 and sure eject...
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:peter_lawrie
ID: 39999479
It is a sata disk in an rdx caddy, not a tape.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39999484
Remove disk and rescan scsi bus if the device is still there.
0
 

Author Comment

by:peter_lawrie
ID: 39999520
That's the point of this posting - I can't physically remove the disk from the caddy!

I can use udisks to remove it from the list of mounted devices, but the disk will not physically eject from the caddy.
Disconnecting and reconnecting the usb cable, mounts the device again and the directory is fully accessible to the OS
This RDX caddy was installed last year and worked correctly for months until late march.
The drive is still recognized within Ubuntu and the backup runs from crontab
There are two other sata cartridges and the procedure until late march was to swap them once weekly. As it is no longer possible to eject the cartridge from the caddy, they cannot be swapped. That does not stop the backup from running.
I have these rdx caddies and sata cartridges running on a number of customer servers running centos linux. They run like clockwork and always eject when unmounted.
0
 
LVL 62

Expert Comment

by:gheist
ID: 39999581
Since you safely removed USB connector no danger ejecting the drive
Put the stapple in emergency eject hole
When cartridge is out disconnect and reconnect drive, then insert cartridge
Try to eject now....
0
 

Author Comment

by:peter_lawrie
ID: 39999610
Already tried a pin in the emergency eject hole!
I removed the caddy from the machine and poked the hole to no effect.
How firmly should I push - I could not detect a switch?
0
 
LVL 62

Accepted Solution

by:
gheist earned 500 total points
ID: 39999677
So in this case you need to call warranty repair... It looks like mechanical damage...
0
 

Author Closing Comment

by:peter_lawrie
ID: 40000189
OK, thanks - same conclusion I had come to!
I thought I had better check before making a warranty claim.
Just now on line to Amazon about replacing the drive and stuck cartridge.
I have the return labels but they are out of stock of the 8631-rdx so had to buy a 8667-rdx (usb3 instead of usb2)
I know usb3 is faster, but server only has usb2
0
 
LVL 62

Expert Comment

by:gheist
ID: 40000326
USB2 will not provide enough power, so you must keep power transformer at hand.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
High Bandwidth Usage 6 75
How yum repo uses sqlite3 to keep metadata about the repository? 2 46
maybe no no httpd.conf 6 62
PHP error function not working on AWS 10 69
Solid State (Hard) Drives aka SSD began to evolve in the computer industry recently. As the name suggests, there are no moving parts in the drives. The drive uses microchip memory store the data, as opposed to the spinning disks of a traditional HDD…
When we purchase storage, we typically are advertised storage of 500GB, 1TB, 2TB and so on. However, when you actually install it into your computer, your 500GB HDD will actually show up as 465GB. Why? It has to do with the way people and computers…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question