Solved

IIS 5.0 to IIS 7.5

Posted on 2014-04-10
6
282 Views
Last Modified: 2014-04-10
when trying to move our web page from a machine running IIS 5.0 to a machine running 7.5 the following error occurs. Can anyone help? Error is attached.
error.png
0
Comment
Question by:ohb1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 83

Accepted Solution

by:
Dave Baldwin earned 500 total points
ID: 39992664
Looks like you don't have a 'web.config' file.  IIS 7.5 is quite different than IIS 5.0.  For one thing, Classic ASP is Not enabled by default.  Here is the 'official' page for running Classic ASP on IIS 7: http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis   There is a link at the bottom of the page for more info.
0
 
LVL 35

Expert Comment

by:Bembi
ID: 39992687
Have you used the same web.config or moved the content into IIS7.5?
It looks like that IIS7.5 tries to interpret the web.config file from IIS5.

Create the new web space in IIS7.5 and copy the content wihtout the web.config file

THe other point what I see is an "access denied", so make sure there are no permission problems on the files. Permissions maybe a bit different is IIT7.5
0
 

Author Comment

by:ohb1
ID: 39992694
What if its already there? Screen shot attached
error.png
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 39992707
It's possible to have features 'installed' but not enabled.  Please read thru the pages I linked and check your settings against them.  There is just a lot more to setting up and operating IIS7 than there was to IIS5.
0
 

Author Comment

by:ohb1
ID: 39992709
OK that helped ! found that while it was installed the service was STOPPED. Once we started the service it is working now !
solution.png
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 39992723
That makes a big difference!
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Objective of This Article In 1990’s, when I was a budding software professional, I had a lot of confusion about which stream or technology, I had to choose to build my career. In those days, I had lot of confusion like whether to choose System so…
Introduction A frequently used term in Object-Oriented design is "SOLID" which is a mnemonic acronym that covers five principles of OO design.  These principles do not stand alone; there is interplay among them.  And they are not laws, merely princ…
The purpose of this video is to demonstrate how to add AdSense Ads to a WordPress Website, and how to set up WordPress to automatically place Ads in Sidebars. This will be demonstrated using a Windows 8 PC. Log into your AdSense account. : Cli…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question