?
Solved

IIS 5.0 to IIS 7.5

Posted on 2014-04-10
6
Medium Priority
?
287 Views
Last Modified: 2014-04-10
when trying to move our web page from a machine running IIS 5.0 to a machine running 7.5 the following error occurs. Can anyone help? Error is attached.
error.png
0
Comment
Question by:ohb1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 83

Accepted Solution

by:
Dave Baldwin earned 2000 total points
ID: 39992664
Looks like you don't have a 'web.config' file.  IIS 7.5 is quite different than IIS 5.0.  For one thing, Classic ASP is Not enabled by default.  Here is the 'official' page for running Classic ASP on IIS 7: http://www.iis.net/learn/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/classic-asp-not-installed-by-default-on-iis   There is a link at the bottom of the page for more info.
0
 
LVL 35

Expert Comment

by:Bembi
ID: 39992687
Have you used the same web.config or moved the content into IIS7.5?
It looks like that IIS7.5 tries to interpret the web.config file from IIS5.

Create the new web space in IIS7.5 and copy the content wihtout the web.config file

THe other point what I see is an "access denied", so make sure there are no permission problems on the files. Permissions maybe a bit different is IIT7.5
0
 

Author Comment

by:ohb1
ID: 39992694
What if its already there? Screen shot attached
error.png
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 39992707
It's possible to have features 'installed' but not enabled.  Please read thru the pages I linked and check your settings against them.  There is just a lot more to setting up and operating IIS7 than there was to IIS5.
0
 

Author Comment

by:ohb1
ID: 39992709
OK that helped ! found that while it was installed the service was STOPPED. Once we started the service it is working now !
solution.png
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 39992723
That makes a big difference!
0

Featured Post

Percona Live Europe 2017 | Sep 25 - 27, 2017

The Percona Live Open Source Database Conference Europe 2017 is the premier event for the diverse and active European open source database community, as well as businesses that develop and use open source database software.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Real-time is more about the business, not the technology. In day-to-day life, to make real-time decisions like buying or investing, business needs the latest information(e.g. Gold Rate/Stock Rate). Unlike traditional days, you need not wait for a fe…
Dramatic changes are revolutionizing how we build and use technology. Every company is automating, digitizing, and modernizing operations. We need a better, more connected way to work together as teams so we can harness the insights from our system…
The purpose of this video is to demonstrate how to set up basic WordPress SEO. This will be demonstrated using a Windows 8 PC. The plugin used will be WordPress SEO by Yoast. Go to your WordPress login page. This will look like the following: myw…
Learn how to set-up PayPal payment integration in your Wufoo form. Allow your users to remit payment through PayPal upon completion of your online form. This is helpful for collecting membership payments, customer payments, donations, and more.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question