Solved

Misbehaving Roamcache!

Posted on 2014-04-11
4
143 Views
Last Modified: 2014-07-08
I have a user who we have switched from exchange (on an SBS2008 domain) to Hosted exchange

The user is still attached to the domain where the previous exchange server still resides but does not use the email facility of that mail server. Instead the domain MX records have been pointed to an external mail server supporting POP3 and Hosted Exchange.

His email is working fine on hosted exchange, he can access from multiple devices no problem. However on his main office PC his Autocomplete feature is behaving weirdly - Everytime he tries to send email to an internal user the message is returned undelivered. The bounce message indicates it is trying to send through the previous exchange server.

I've tested the Roamcache file using some software called nk2edit and I can see that the internal addresses are stored under EX instead of SMTP - Even if I delete these out (there are only 10-15) and save the Roamcache file next time we try to send to an internal user again it overwrites the Roamcache with the previous version and all EX users return.

I think the obvious answer is that for some reason the previous mail server is interfering, is there a way I can remove that mail server from the equation without losing it as an archive?
0
Comment
Question by:MadPC
  • 2
  • 2
4 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39995389
If Exchange is installed then it will try and get involved with email. Due to the way that Autodiscover works, it queries the domain first and only if a record does not exist will it try to use external DNS records.

You could try changing the value of

get-clientaccessserver | select identity, autodiscoverserviceinternaluri

to match the host name used for external Autodiscover. That should force the clients to go out to the external host even if they do find the internal Autodiscover entry.

Realistically though, unless you were in a Hybrid with Office365 you should remove the on premise Exchange server.

Simon.
0
 
LVL 1

Author Comment

by:MadPC
ID: 40001986
Hi Simon thanks for the advice

I was thinking the same thing here and I've found a 'disable server' option within the Exchange console which might be easier as we don't need it any more but would be good to keep a copy in case needed.

I did have a read through this thread which offers an alternative process (albeit controversial) but I would rather click a button and turn it all off if that can be done?

Image attached, can anyone confirm if that's the right setting? I don't want to 'disable server' if it's going to knock my main server offline and not the Exchange server as we hope?

thanks
0
 
LVL 1

Author Comment

by:MadPC
ID: 40001992
Can't see the attachment so trying again...exchange disable button?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 40003793
There is no "disable server" option in Exchange. I was curious what you had found. The screenshot explains everything.

That option is to disable the Receive Connector - all that will do is stop the server from receiving email. My previous advice still stands.

Simon.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now