[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 595
  • Last Modified:

Inconsistent popup positioning in IE

Recently an Expert assisted me in styling the position of a calendar popup, such that it appears centered over the icon which launched it.   This is working under Chrome, Firefox and Safari, but in IE 8, 10 & 11 the popup is too high.   Curiously, the popup is perfectly positioned if the page is launched from a local file, but not on the server.

Could you verify this observation and advise how to adjust that?  Please visit www.mauitradewinds.com/RezEasy/availability.html and click on a calendar icon.

 Here is the styling code (which is included in style/calendar1.css, and a screen shot of the displaced popup is attached.  

.calendar table {
  position: absolute;
  left: 50%;
  top: 50%;
  margin: -115px 0 0 -100px;
  border-top: 1px solid #000;
  border-right: 1px solid #fff;
  border-bottom: 1px solid #fff;
  border-left: 1px solid #000;
  font-size: 11px;
  color: #000;
  cursor: default;
  background: #c8d4d0;
  font-family: tahoma,verdana,sans-serif;
}

Misplaced popup
0
ddantes
Asked:
ddantes
  • 5
  • 2
  • 2
  • +1
1 Solution
 
Dave BaldwinFixer of ProblemsCommented:
Your first problem is that the av0001.html page is an HTML5 page and IE8 doesn't understand HTML5.  Firefox says you have a few CSS and javascript errors too.  I don't know how important they are.
0
 
ddantesAuthor Commented:
Thank you, Dave.  I'm not so concerned about IE8.  Can you test that popup with IE 10 or IE11 and let me know if it appears over the calendar icon on your machine?
0
 
Dave BaldwinFixer of ProblemsCommented:
No, someone else will have to do that.  I don't have them.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
ddantesAuthor Commented:
Someone did test it in IE11, and the popup was centered over the left calendar icon (which is the icon they clicked), as intended.  This is also what I see if I open a copy of the page on my local drive.

So, why am I seeing a different popup position on the internet than what I see on my local drive, and what others see on the internet?   It seems that an excessively-negative top margin is being applied to my view (image in original question).

Someone else's view the popup
0
 
David Johnson, CD, MVPOwnerCommented:
I don't get any popups just get a full screen calendar.. you can't unselect a beginning date
0
 
ddantesAuthor Commented:
Thank you for participating.  When you visit the page, please look at the lower form.  There are calendar icons for arrival and departure dates.  When an icon is clicked, there should be a calendar popup centered over that icon.  Under IE 8, 9, 10 and 11, the popup appears high on the page in my browser, instead of centered over the icon.  But if I open the same page from my local drive, instead of a server, the popup appears where it belongs.  Other browsers render the popup over the icon, as well.  I'd like to know what you observe.
0
 
Michel PlungjanIT ExpertCommented:
I see the same image
as you

in my IE10

I think when you load it from your server, it is possibly you are in compatibility mode- Hit F12 and look
0
 
ddantesAuthor Commented:
Thank you.  I couldn't tell by hitting F12.  But when I un-ticked "Display Intranet Sites in Compatibility View" the issue resolved, and the popup appears in the correct placement.   Could you clarify what happened?
0
 
Michel PlungjanIT ExpertCommented:
Hitting F12 opens the console and at the top it would say
IE10 compatibility mode instead of Standards mode

Compatibility mode is only needed for older websites that have special IE8 or lower coding, which interferes with especially the box model e.g. placements
0
 
ddantesAuthor Commented:
My console in IE11 doesn't say either compatibility mode or Standards mode.  However, un-ticking the option to display intranet sites in compatibility view resolved this mystery.  Thanks!
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 5
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now