Unable to kill mcafee service on win 2008

Posted on 2014-04-13
Last Modified: 2014-04-13
I was trying to uninstall mcafee av 8.8 and the uninstall looks to have gotten corrupted. In task manager I still see the mcshield.exe process and in service the mcshield service is still there and running. But there is no stop, or start commands. Looks like the service is still in protected mode from being able to be stopped.

I've tried using pstools to kill the service, msconfig all say access denied. I tried deleting and taking ownership of the mcafee entries in the registry but I get access denied.

Is there any ways t kill, or remove the entries from regedit. There are about 700 entries for mcafee in the registry.
Question by:rdefino
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
LVL 25

Expert Comment

by:Tony Giangreco
ID: 39997789
Try using Ccleaner. It has an uninstall utility for situations like this
LVL 15

Accepted Solution

Perarduaadastra earned 500 total points
ID: 39997801
LVL 16

Expert Comment

ID: 39997804
Just to add directions for tool link above. You MUST reboot.
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.


Author Comment

ID: 39997807
I already tried ccleaner and mcafee doesn't show in the programs and feature section to uninstall.

As for MCPR that's only for consumer products. I;m running mcafee enterprise AV 8.8
LVL 25

Expert Comment

by:Tony Giangreco
ID: 39997815
Try uninstalling it in safe mode

Author Comment

ID: 39998079
I've requested that this question be closed as follows:

Accepted answer: 0 points for rdefino's comment #a39997807

for the following reason:

Wow, it worked for enterprise version. Thanks!!
LVL 15

Expert Comment

ID: 39997845
What worked for uninstalling the enterprise version? The MCPR tool, the reboot, or uninstalling in safe mode?

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Sync home folder not working- urgent 13 55
SYSVOL folder permission security best practice ? 14 140
Chromebook has symptoms of virus infections 2 52
Help Fixing Zeus Virus Mess 11 70
A procedure for exporting installed hotfix details of remote computers using powershell
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question