Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco Broadband Information

Posted on 2014-04-14
9
Medium Priority
?
252 Views
Last Modified: 2014-04-24
Hi we have a Cisco router that I am not to familiar with regards to commands etc.

However we are changing Broadband from adsl to fibre optic

can somebody help to guide me in changing the PPPOA settings etc. on the relevant ports
0
Comment
Question by:pepps11976
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 47

Expert Comment

by:Craig Beck
ID: 40000966
If you're going from ADSL to fibre you'll probably need to use PPPOE instead.

What router do you have and who is your ISP?
0
 

Author Comment

by:pepps11976
ID: 40001036
Yes you are right the router is Cisco 887VAW and I believe the ISP is BT
0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 40001420
Ok try this...

service dhcp
!
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool DHCP
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254
 dns-server 194.72.6.57 194.74.65.68
!
ip multicast-routing
!
interface Ethernet0
 no ip address
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Vlan1
 ip address 192.168.1.254 255.255.255.0
 ip flow ingress
 ip pim query-interval 126
 ip pim sparse-dense-mode
 ip nat inside
 ip virtual-reassembly in
 ip route-cache policy
 ip tcp adjust-mss 1452
 no shutdown
!
interface Dialer0
 mtu 1492
 ip address negotiated
 ip pim query-interval 126
 ip pim sparse-dense-mode
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 ip igmp version 3
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ppp authentication chap callin
 ppp chap hostname bthomehub@btbroadband.com
 ppp chap password 0 bthomehub@btbroadband.com
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer0 overload
!
ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit

Open in new window

0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 

Author Comment

by:pepps11976
ID: 40001442
Ok if the server is issuing DHCP do I just miss that bit out?

What about username and password? For the connection

Sorry for newbie questions
0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 40001462
Yep if you already have a DHCP server just ignore that bit.  You'll need to update the following lines with your IP range though incase it's different to what you use...

interface Vlan1
 ip address 192.168.1.254 255.255.255.0
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any

Open in new window


Obviously the Vlan1 IP address should be whatever your DHCP server gives to the clients as their default-gateway.

The username and password is right in my example.  BT use a generic user/pass for all Infinity PPPoE connections.
0
 

Author Comment

by:pepps11976
ID: 40001530
ok I will keep you posted

so I f I make the amendments and copy and paste all should be good?
0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 40001546
Should be.

I wrote that config for my 1841 router (also on Infinity).
0
 

Author Comment

by:pepps11976
ID: 40002177
ok just an update

so the old broadband was plugged directly into the VDSL port at the back of the router

so basically I just need to configure one of the LAN ports with the old ISP settings

LAN Port 0 is my internal LAN so I would like to use Lan Port 1 as my gateway.

I assume copying and pasting the above will still work

but what command would show me the old settings on the VDSL port as I cannot remember the username.

and also I do not need to configure the internal side on the router as that is already done so would the above still apply?
0
 
LVL 47

Accepted Solution

by:
Craig Beck earned 2000 total points
ID: 40002914
If the internal side is already done you just need this...

ip multicast-routing
!
interface Ethernet0
 no ip address
!
interface Ethernet0.101
 encapsulation dot1Q 101
 pppoe-client dial-pool-number 1
!
interface Dialer0
 mtu 1492
 ip address negotiated
 ip pim query-interval 126
 ip pim sparse-dense-mode
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 ip igmp version 3
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ppp authentication chap callin
 ppp chap hostname bthomehub@btbroadband.com
 ppp chap password 0 bthomehub@btbroadband.com
!

Open in new window


The VDSL should plug straight into the DSL port on the router - it auto-detects based on the config you enter, so the Ethernet controller is VDSL and the ATM interface is ADSL.

The 4-port switch is for your LAN, so any of the 4 RJ45 ports will be your existing LAN.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question