can't delete .vmdk file

Posted on 2014-04-14
Last Modified: 2014-04-15
Good afternoon to all Expert,
Excuse my English.

I have delete from disk 2 replicate on my Virtual Server.  When I browse in my datastore, I still see the two replicate but with only the *.vmdk file.  I can't delete it, it always gave me error.  can't delete file.

I don't know what to do.  I have version essentials of VMware and I can't get support.

Please help me find, what is wrong.

Question by:nancytherrien
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 2
  • +1
LVL 16

Expert Comment

ID: 39999687
did you right click and delete "virtual machines" from the vm console?  Make sure the vms are shutdown and powered off.

Author Comment

ID: 39999715
I did right click and delete the virtual machine from disk, which is a replicate, but it is still a part in the datastore.  I did that for two replicate this morning and the same result for both.
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39999724
Try with Free Veem backup Edition

they have in build tool ie File manager with the help of that you can delete that file
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.


Author Comment

ID: 39999732
Why the free edition of veeam ?  I do have Veeam Backup and Replicate 7.0.
Where do I install the free version ?
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39999746
File manager tool should be available in that too, check using that you can delete that file

Author Comment

ID: 39999878
Still not working.  But getting a better error message.  please see attached file.

I have gotten the same error for both machine.

LVL 120

Accepted Solution

Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 40000056
Before you try to Delete ANY VMDK?

Step Back, and Have a think, if the file is locked, because

1. it's being backed-up?

2. attached to any VM Backup appliance?

otherwise you will have to go through the "unlock procedure"

and to be honest you might as well restart your Host and try again, after a restyart.
LVL 120
ID: 40000059
Hang ON here!

Just confirm, do you have a SNAPSHOT?

see my EE Article to check

HOW TO: VMware Snapshots :- Be Patient

Author Comment

ID: 40000081
Just been able to delete the file but now I have 1 server that is not working anymore.  I can't understand why disk came mixted up like that.

My replicate of BAK-02 is not working anymore also, cause it is looking for a file on the one I have deleted.

Is there a way to see what file or server use what disk and what part of disk that are not involved in ?


Author Closing Comment

ID: 40000083
good and fast answer.  Thanks
LVL 120
ID: 40000098

Check the VM Settings, and Virtual Disks, e.g. Read my EE Article, and check if it was using a Snapshot Disk, which you have deleted.

Author Comment

ID: 40001482
Good Morning,  I have read your article.  It explain a lot of thing.
It's too late for me now, I have 3 Virtual machine not working anymore and replicate also.  I will have to rebuild everything.
Thanks for your help.

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Creating 2 network Adapters via PowerCli 7 37
esxi root user permission 7 79
VM replication scenario and caveats ? 6 119
PartedMagic Secure Erase 14 21
When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Teach the user how to delpoy the vCenter Server Appliance and how to configure its network settings Deploy OVF: Open VM console and configure networking:
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question