[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 96
  • Last Modified:

Modbus TCP client fails on Windows 7 --- works fine on XP

Our client application works fine on Windows XP.
The application scans approx 10 registers without failures at a scan rate of 100 milli secs.
When used on Windows 7 the app works for a few seconds and is then unusable.
If the scan rate is decreased to 10 seconds the app works without failures
If a scan rate of 2.5 seconds is used some failures are noticed.

The link http://modbus.control.com/thread/1341225864 refers to many similar issues.
However a fix suggested below did not work.
netsh interface tcp set global autotuninglevel=disabled

Please advise.

Help moderator please... I would like to increase the points 1000 but "Edit question" doesn't allow ??
0
mattie13
Asked:
mattie13
  • 2
  • 2
2 Solutions
 
bbaoIT ConsultantCommented:
a very first clarification. did you try running the application in XP compatible mode under W7?

i don't mean the XP Mode of W7, which is about VM.

right-click the executable in Windows Explorer, choose Properties then Compatibility tab, change the level to XP, press OK to save the settings. run the executable again.
0
 
BembiCEOCommented:
Just another idea what may underline bbao answer....
I have seen a lot of times applications, which just have a problem with timing, means multithreading and distribution on several processors. If this doesn't work fine, it is possible that the application creates projcessor jobs, which do not run in a multitasking environemnt with several processors. If jobs are distributed to several processors, it may run in an undefined stated, if the application doesn't put the timing into account.

Means, not every application is multitasking, multiprocessor capable.

You may tr to create a virtual WIn7 machine (if your application works with that) and assign only one processor to this virtual machine. If this works, but not with several processors, you can be sure, the application can not handle it.

So the solution maybe in fact, to either try the XP compatibility mode, which switches off some of the capabilities of Win7, to run int in a virtual machine with one single processor or to just leave in on a XP machine.
0
 
mattie13Author Commented:
Thanks to bbao and Bembi.
Ill try your advice and feedback asap.
0
 
mattie13Author Commented:
I've requested that this question be deleted for the following reason:

Neglected status
0
 
BembiCEOCommented:
So, where is the feedback asap?
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now