Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

WIN -standalone PC - how to configure static IP

Posted on 2014-04-14
16
Medium Priority
?
663 Views
Last Modified: 2014-04-16
Dear All,

please advice the steps ..

........For some software testing purpose  I need to have below requirement

how to configure static IP address  on standalore PC
-on Windows 7/8.

So that, when I ping my hostname..it should come with IP address.

Thanks
0
Comment
Question by:mac_g
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 2
  • +3
16 Comments
 
LVL 35

Assisted Solution

by:Dan Craciun
Dan Craciun earned 300 total points
ID: 40000934
Control Panel->Network and Sharing Center->Change adapter settings
Right click Ethernet, select Properties.
Click on Internet Protocol Version 4 (TCP/IP)->Properties.
Check "Use the following IP adress"

HTH,
Dan
0
 
LVL 26

Assisted Solution

by:Fred Marshall
Fred Marshall earned 300 total points
ID: 40000938
Control Panel / Network and Sharing Center / Change Adapter Settings

Right click on the network adapter / Select Properties

Highlight Internet Protocol Version 4 (TCP/IP v4)
Click on the Properties button below

Manually enter the desired IP address, subnet mask.
You should be able to get by without a gateway address or DNS addresses.

OK. OK.
0
 
LVL 10

Assisted Solution

by:Scott Thomson
Scott Thomson earned 150 total points
ID: 40000943
I'm going to give you a link with pictures ^_^
it is exactly as they have said but just in case you do not understand.. pictures always help

http://www.howtogeek.com/howto/19249/how-to-assign-a-static-ip-address-in-xp-vista-or-windows-7/

When you see the DNS settings you will most likely not need these if you just want to ping / access the machine with a switch or something.
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
LVL 23

Assisted Solution

by:Radhakrishnan R
Radhakrishnan R earned 600 total points
ID: 40000960
Hi,

Since you would like to assign a static IP, you need to check the IP exclusion range from your DHCP scope and assign a IP within that range. Otherwise it will get clash if you give any IP address as you wish.

Note down a IP address from the DHCP exclusion list and perform a ping <IPAddress> and make sure that it's not giving reply.

Once you confirmed it, go to that PC Start>>run>>ncpa.cpl>>select the N/W card properties and select TCP/IPv4>>Properties>>Select Use the following IP address and set the IP address and subnet mask>>Also, set the DNS accordingly otherwise it won't resolve the query.

Hope this helps.
0
 

Author Comment

by:mac_g
ID: 40001083
I have 4 Ethernet ..

2 VM's , one for WI-FI/ other is free for LAN
---
I tried above setting below is results .. Please advice further ,

my IP for LAN adaptor not shown
==================

D:\Oracle\Middleware\asinst_1\config\reports\bin>ipconfig

Windows IP Configuration


Wireless LAN adapter Local Area Connection* 3:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::e952:7390:39e6:89e2%4
   IPv4 Address. . . . . . . . . . . : 10.173.25.101
   Subnet Mask . . . . . . . . . . . : 255.0.0.0
   Default Gateway . . . . . . . . . : 10.128.128.128

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : CN31.com

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::64f7:2ff9:dab4:2824%7
   IPv4 Address. . . . . . . . . . . : 192.168.182.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::89cf:f123:1a06:c5e%8
   IPv4 Address. . . . . . . . . . . : 192.168.220.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{24346F48-AD55-4E8C-B8C8-A87429EA54C4}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{A238839D-4AAF-4E72-8B55-95D13CBB59DA}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{C17ACE72-F70A-4B4C-8663-03AACFF905DF}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

D:\Oracle\Middleware\asinst_1\config\reports\bin>
0
 
LVL 23

Expert Comment

by:Radhakrishnan R
ID: 40001206
Hi,

what IP address you set in that adapter? make sure that it's enabled. Start>>run>>ncpa.cpl>>Right click the LAN adapter and Enable. Are you able to ping the IP address which you set?
0
 

Author Comment

by:mac_g
ID: 40001265
the IP I configured was : 192.168.1.1
Ethernet adopter again, I disabled/ enabled

then tried to ping .. getting below message ..
please advice further


D:\Oracle\Middleware\asinst_1\config\reports\bin>ping PC-54

Pinging PC-54 [fe80::89cf:f123:1a06:c5e%8] with 32 bytes of data:
Reply from fe80::89cf:f123:1a06:c5e%8: time<1ms
Reply from fe80::89cf:f123:1a06:c5e%8: time<1ms
Reply from fe80::89cf:f123:1a06:c5e%8: time<1ms
Reply from fe80::89cf:f123:1a06:c5e%8: time<1ms
0
 
LVL 35

Accepted Solution

by:
Dan Craciun earned 300 total points
ID: 40001275
You got an answer on the IPv6 IP.
0
 

Author Comment

by:mac_g
ID: 40001289
I have de-selected IPv6 option.
 
only enabled IPv4.     then disabled/enbled  Ethernet LAN.

IP configured was  -192.168.1.1


but  when I ping, i am getting above results.
please advice further
0
 
LVL 23

Assisted Solution

by:Radhakrishnan R
Radhakrishnan R earned 600 total points
ID: 40001319
Hmm..you are getting reply through mac address rather than IP. Have you created a host A record for this machine? if already not, please create an A record associated ptr and see it works.

It should be IPv6 enabled though you disabled manually. You need to disable it from registry

Us this http://support.microsoft.com/kb/929852
0
 

Author Comment

by:mac_g
ID: 40001336
that Means I need to download and run the MSI file.
0
 
LVL 23

Assisted Solution

by:Radhakrishnan R
Radhakrishnan R earned 600 total points
ID: 40001338
Yes. Select the appropriate OS and download, run it on that server.
0
 

Author Comment

by:mac_g
ID: 40001371
am not able to install

my OS is -win8

Can you please advice correct one file to install
0
 
LVL 23

Assisted Solution

by:Radhakrishnan R
Radhakrishnan R earned 600 total points
ID: 40001412
In the same article, expand "For more information" section>>Manually disable or re-enable IPv6 or its components, perform that and see it's working.
0
 
LVL 1

Assisted Solution

by:ProTechComputing
ProTechComputing earned 150 total points
ID: 40001565
I just did a quick test with ipconfig /all in command prompt.

If you're ON PC-54 and Ping PC-54, you'll get the results you have - whether IPv6 is enabled or not.

Once you set the static IP address on PC-54, if you ping it from any other computer, it should give you the computers IPv4 address.

=======================================

On a side note - you must be on a HUGE LAN, running a Class A subnet?!?  255.0.0.0 as noted in your ipconfig information under Wireless LAN

Also...  If you're going to set the static IP on PC-54 and ping it from another computer, you should set both to the same subnet i.e.  10.x.x.x for your testing.
0
 
LVL 26

Assisted Solution

by:Fred Marshall
Fred Marshall earned 300 total points
ID: 40002134
I suggest you do that same ping like this:

ping -4 PC-54

This will force the responses to be in ipv4 format - which is more readable for you.

I don't see any signs to suggest a conflict but I would not use 192.168.1.1 because it's so typically a router address.  Use something else just to be sure.  Your setup is complex enough that this may matter.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question