Solved

Disable Delete All in Outlook 2010

Posted on 2014-04-14
5
247 Views
Last Modified: 2014-04-18
Is there a way to disable the Delete All option when you do a right click on the inbox folder?

Thanks

nitenKumar
DeleteAll.JPG
0
Comment
Question by:Niten Kumar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 10

Expert Comment

by:Scott Thomson
ID: 40000948
There appears to be no method to do this without major modifications to outlook. But do you know that outlook can recover deleted data for up to 30 days using recover?

so unless someone is silly enough to delete it twice you should be ok :)
0
 
LVL 6

Author Comment

by:Niten Kumar
ID: 40003089
Thanks for your answer.  Would you have any idea on how to do these major modifications in outlook.  Would it be possible to do this using group policy.  I have managed to disable the delete icon and shortcut key using group policy.
0
 
LVL 10

Expert Comment

by:Scott Thomson
ID: 40003093
No as far as I have investigated (that's a lot) there is no reg key associated with it.
there is no GPO that can be applied
There is no application that has been developed.

It would be a custom job by a coder if at all possible.
Is there a particular reason you would like to accomplish this task.? perhaps with a little more information we could suggest some kind of workaround for you.
0
 
LVL 6

Author Comment

by:Niten Kumar
ID: 40005483
Yes there is a reason.  An email account has to be created and it will be shared by four people in our organization.  No one should be able to delete the emails.  Using group policy I have managed to disable the delete button and shortcut.  What I haven't been able to stop is delete of emails using Delete key on the keyboard and the right click on inbox and delete all option.

Thanks
0
 
LVL 10

Accepted Solution

by:
Scott Thomson earned 500 total points
ID: 40005757
Just dont give the users full access on the mailbox man.. Instead of using a security group or a adding them directly to the mailbox. Give 1 user (yourself or the head person in that team) delegate access on the mailbox and folders. But dont give full permissions..

Either that or auto forward a duplicate to a second mailbox as a spare..
0

Featured Post

Free Webinar: AWS Backup & DR

Join our upcoming webinar with experts from AWS, CloudBerry Lab, and the Town of Edgartown IT to discuss best practices for simplifying online backup management and cutting costs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question