Solved

Exchange 2003 > 2010 Co-Existance Issues replicating all PF Content

Posted on 2014-04-15
6
714 Views
Last Modified: 2015-01-31
I am currently performing an Exchange 2003 to 2010 migration, I am nearly at the stage to start migrating users but need to ensure my Public Folders are fully replicated before i do so but i am still getting massive differences in the item count with some Public Folders

I have been using ExFolders (2010) and PFDAVAdmin (2003) to run a content report on the PF hierarchy, the results are then inserted into Excel and compared for item count. I have 29 troublesome Public Folders (out of 300ish) which are behind the Ex2003 item count by 500-1500 items. Replication has been running for over a week now and im getting concerned that i have a major blocker here

On the 29 PF all have EX2010 as a replication partner, replication is set to Urgent and Always, Expert logging is enabled on all PF related audits and i have tried to manually re-send changes several times.

Exchange Setup
2003 6.5 build 7638:2 SP2
1x 2003 Exchange Server (Win 2003)
2010 SP3 RU5
2x 2010 Exchange HT & CAS (Win 2012 R2)
2x 2010 Exchange Mailbox (Win 2012 R2)

All public folders are on MBX01 at the moment, and all replication settings are set to MBX01

Event Logs

MBX Server - Many Informational 3031 Replication Incoming Messages

HUB/CAS Server - An error event is noticed when performing a manual re-send changes -

Event 1020, MSExchange Store Driver
The store driver couldn't deliver the public folder replication message "Folder Content Backfill Response (<exch2003svr>-PubIS@domain.co.uk)" because the following error occurred: Property validation failed. Property = [{00062003-0000-0000-c000-000000000046}:0x8111] TotalWork
Error = The property, (1525252320), is out of range. The valid range is from 0 to 1525252319...

I am really struggling to nail this replication, does anyone have any ideas?

Apologies for the huge post but i didn’t want to miss any details out :)

Edit -

I have also noticed these related errors on the HUB/CAS Servers

All Event 1020, MSExchange Store Driver

The store driver couldn't deliver the public folder replication message "Folder Content Backfill Response (<exch2003svr>-PubIS@domain.co.uk)" because the following error occurred: Cannot open embedded message..

The store driver couldn't deliver the public folder replication message "Folder Content Backfill Response (<exch2003svr>-PubIS@domain.co.uk)" because the following error occurred: The message content has become corrupted..

The store driver couldn't deliver the public folder replication message "Folder Content Backfill Response (<exch2003svr>-PubIS@domain.co.uk)" because the following error occurred: Property validation failed. Property = [{00062003-0000-0000-c000-000000000046}:0x8110] ActualWork
Error = The property, (1525252320), is out of range. The valid range is from 0 to 1525252319...
0
Comment
Question by:Stuart Lupton
  • 3
  • 2
6 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40001814
The only time I see these errors is when there is interference from a third party application.
AV, Antispam etc can have real problems with the replication traffic. Firewalls scanning the SMTP traffic can as well.

Do you have AV software on any of the machines involved? If so, do they have the correct exclusions in them?

Some minor differences in public folder item count isn't unusual, as you get corrupt items, but large numbers like you have indicated is odd.

Worst case scenario (depending on the number of items in the folder) is to recreate the folder on 2010, then move the content across through Outlook.

Simon.
0
 
LVL 2

Author Comment

by:Stuart Lupton
ID: 40002445
Thanks for your reply, I have a\v installed and have temporary disabled on both 2003 & 2010 while I set the exception rule policies. Concentrating on the worst affected folder "calendar" which is synced 83000/84324 that's 1324 items out. I logged onto exchange 2003 and performed a resend changes 99999 days. I noticed many replication incoming messages on my mbx server but still three error event 1020 MSExchangeStoreDriver alerts on the hub/cas servers. After running a content report the count is now 83044 after an hour so still not sure :( I will hammer the replication tomorrow to see if this makes any difference

Is there a way to get the item count using the Get-PublicFolder cmdlet?

If I was to backup to .pst then restore in exchange 2010 would the replication continue while I'm still in co-op mode? Can you confirm the process for me - logon as 2003 user, outlook 2010 > open > import > export to file > .pst > select pf > save to desktop. Logon as 2010 user, outlook 2010 > open .pst then drag on top of the public folder to restore - I presume I will then have to reset permissions or would this retain them.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 40003797
The only way to get item count is with get-publicfolderstatistics - get-publicfolder is about the configuration, not the content.

Disabling AV often is not enough, because it will still have its fingers in Exchange. If AV is suspected as the problem then removing it and rebooting the server is the only way to get rid of the content.

The method you have outlined using PST files will not work. You cannot drag and drop a folder in to Public Folders from a PST file - it works on the content basis only. I also wouldn't do it with the existing folder, as that will just confuse Exchange. If you are going to use that method then create new folders. Permissions will be lost though.

Simon.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 2

Author Comment

by:Stuart Lupton
ID: 40004347
Thanks I will try the reboot and give it another few days, if nothing further comes through I will look further into the manual migration. I will feedback soon :)
0
 
LVL 2

Author Closing Comment

by:Stuart Lupton
ID: 40012142
Thanks :)
0
 

Expert Comment

by:Yeison
ID: 40581295
Hello Stuart,

I'm in a similar process with a coexistence Exchange 2003 and 2010. I started the Public folders replication about a week ago and I though everything was replicated fine after checking random some of the PF.
Unfortunately, yesterday one of the user complained about missing almost 4000 task items from a Public Folder that is being use just for tasks and special Custom Forms...... just 217 items were synchronized. After researching for a while I found exactly the same error you had..
"The store driver couldn't deliver the public folder replication message Folder Content Backfill Response.... Error = The property, (1525252320), is out of range. The valid range is from 0 to 1525252319...

I tried already
- Resend all items......
- Remove item-level permissions with PFDAVAdmin  
- dismount and fix with Isinteg.exe
Still not replicating...
- I trying right now with the option of removing  AV in both servers and restarting (AV Bitdefender). will give feedback later.     Update.... AV uninstalled, both servers restarted. Replication Resend.. still same errors :(

Just wonder how did u finally solved the issue.

Thanks a lot for your time and support.

Yeison
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In-place Upgrading Dirsync to Azure AD Connect
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question