Solved

Glue Record

Posted on 2014-04-16
12
967 Views
Last Modified: 2014-04-18
Hi

I have installed Webmin on 3 CentOS machines and setup BIND on all of them, working fine. The names are e.g. ns1.myhosting.net, ns2.myhosting.net, ns3.myhosting.net. I have purchased all the domains from NameCheap. I want to Namecheap control panel > Nameserver Registration and added all three nameservers with their IPs.
The DNS of my domain myhosting.net is hosted with ClouDNS.net. I went there and created three A Records one of each nameserver.

Then I purchased another domain for my client clientdomain.com and set its nameservers to mine (ns1.myhosting.net, ns2.myhosting.net, ns3.myhosting.net).

I created DNS zones on my BIND server. Everything works great except when I check clientdomain.com on intodns.com it says following:

The parent nameserver d0.info.afilias-nst.org is not sending out GLUE for every nameservers listed, meaning he is sending out your nameservers host names without sending the A records of those nameservers. It's ok but you have to know that this will require an extra A lookup that can delay a little the connections to your site. This happens a lot if you have nameservers on different TLD (domain.com for example with nameserver ns.domain.org.)


What I understand from the above message is I need to create A record for each of three nameservers (ns1.myhosting.net, ns2.myhosting.net, ns3.myhosting.net) in ClouDNS..net which I have already done and have confirmed that by pinging and running dig command.

I will be really thankful if someone can help me to fix this.

Habib
0
Comment
Question by:sysautomation
  • 5
  • 5
  • 2
12 Comments
 
LVL 11

Expert Comment

by:Murfur
ID: 40003856
It is possible that you missed a step - yes, you have to register each of the name servers but you ALSO have to create the A records in your domain zone file.

Add each A record to the zone file as you would for any other hosts in that domain i.e. a name and an IP address. Then check the name server registration.
0
 

Author Comment

by:sysautomation
ID: 40003990
HI Murfur

Thanks but I am 100% sure that I have already created A Records for each of ns1.myhosting.net, ns2.myhosting.net, ns3.myhosting.net and when I dig I get following:

;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28992
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ns1.myhosting.net.            IN      A

;; ANSWER SECTION:
ns1.myhosting.net.      3600      IN      A      <MYIP>


This is same for other two NS also.

Any more thoughts please?
0
 
LVL 11

Expert Comment

by:Murfur
ID: 40004073
In that case it would appear that the parent DNS server is simply not responding with the glue data to a query as opposed to anything you have/have not done.

If the nameservers have been registered correctly then I would suggest you get in touch with Namecheap support.
0
 

Author Comment

by:sysautomation
ID: 40004162
Thanks. Just to confirm should I contact namecheap or cloudns as namecheap is providing domain only whereas the dns for myhosting.net is hosted with cloudns?
0
 
LVL 11

Expert Comment

by:Murfur
ID: 40004242
Ah, OK then, so the problem is that you have registered your nameservers with namecheap but any initial DNS query goes to cloudns which does not have the corresponding glue records. In which case you need to add glue records at clouds assuming you can (I couldn't find reference on their site) so you may need to contact their support team.

Is there a specific reason why the DNS is with cloudns and not with namecheap's own DNS service?
0
 

Author Comment

by:sysautomation
ID: 40004506
I moved to ClouDNS as exporting/importing Zones was much easier whereas with Namecheap it was very difficult.

ClouDNS replied:

The glue records (child name servers) need to be defined at the domain's registrar. If you can't find them you need to ask the registrar for help.

NameCheap replied:

Please contact your Hosting company in order for them to create A-records for private nameservers ns1.myhosting.net and ns2.myhosting.net as they are absent at the moment.

These private nameservers are registered correctly at the moment, but A-records should be created in order for these nameservers to be active.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 11

Expert Comment

by:Murfur
ID: 40004543
Okaaaaayyy...

Cloudns say glue records need to be defined at the domain registrar which means namecheap.

Namecheap say A records need to be created on the hosting provider which means cloudns.

There can't be any harm from adding A records at namecheap too.

Try that but bear in mind you should allow time for the changes to propagate before you can expect to see a result. Sometimes it is pretty quick but other times can take a few hours.
0
 

Author Comment

by:sysautomation
ID: 40004570
> There can't be any harm from adding A records at namecheap too.

Once I point non-namecheap DNS, there is no option available to enter any DNS records.
0
 
LVL 11

Assisted Solution

by:Murfur
Murfur earned 250 total points
ID: 40005168
Bingo!

Perhaps the glue records at namecheap cannot function properly without the local A records. The SOA records will be with the registrar so there will be a zone file there too. I'm guessing that the namecheap control panel UI is preventing your access to create the A records because the primary dns is external so I see two options:

1. direct name servers back to name cheap, add the records then send it back to cloudns
2. talk to namecheap support again and see if they can do it all for you.

Obviously, option 2 is the preferred route! :)
0
 
LVL 61

Accepted Solution

by:
gheist earned 250 total points
ID: 40006703
It is the upstream nameserver configuration choice. There is no issue or problem to solve.
0
 

Author Comment

by:sysautomation
ID: 40008495
Namecheap agrees with gheist. Following is there reply:

Please note that this information is not marked as error on intodns but as just an information message. We have checked and can see that your nameservers are configured correctly. They have both glue and A records set with correct IPs.
0
 
LVL 61

Expert Comment

by:gheist
ID: 40008862
Doc here
If remote server authoritatively knows IP of yur NS and the remote software is BIND9.x then it saves client's recursive resolver one extra query (or some recursive resolvers van be forced to ignore such hint anyway)
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Resolve DNS query failed errors for Exchange
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now